8 Replies Latest reply on Jan 10, 2014 2:50 AM by Ramesh Routray

    persistence.xml - not all data table are being created jbpm5

    Odelya Holiday Novice

      HI!

       

      I have the following persistence.xml file:

       

      <persistence version="1.0"
                xsi:schemaLocation="http://java.sun.com/xml/ns/persistence http://java.sun.com/xml/ns/persistence/persistence_1_0.xsd http://java.sun.com/xml/ns/persistence/orm http://java.sun.com/xml/ns/persistence/orm_1_0.xsd"
                xmlns:orm="http://java.sun.com/xml/ns/persistence/orm" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                xmlns="http://java.sun.com/xml/ns/persistence">
                <persistence-unit name="org.mycompany.task">
                            <provider>org.hibernate.ejb.HibernatePersistence</provider>
                            <class>org.jbpm.task.Attachment</class>
                            <class>org.jbpm.task.Content</class>
                            <class>org.jbpm.task.BooleanExpression</class>
                            <class>org.jbpm.task.Comment</class>
                            <class>org.jbpm.task.Deadline</class>
                            <class>org.jbpm.task.Delegation</class>
                            <class>org.jbpm.task.Escalation</class>
                            <class>org.jbpm.task.Group</class>
                            <class>org.jbpm.task.I18NText</class>
                            <class>org.jbpm.task.Notification</class>
                            <class>org.jbpm.task.EmailNotification</class>
                            <class>org.jbpm.task.EmailNotificationHeader</class>
                            <class>org.jbpm.task.PeopleAssignments</class>
                            <class>org.jbpm.task.Reassignment</class>
                            <class>org.jbpm.task.Status</class>
                            <class>org.jbpm.task.Task</class>
                            <class>org.jbpm.task.TaskData</class>
                           <class>org.jbpm.task.SubTasksStrategy</class>
                           <class>org.jbpm.task.OnParentAbortAllSubTasksEndStrategy</class>
                            <class>org.jbpm.task.OnAllSubTasksEndParentEndStrategy</class>
                            <class>org.jbpm.task.User</class>
                            <class>org.drools.persistence.session.SessionInfo</class>
                          <class>org.jbpm.persistence.processinstance.ProcessInstanceInfo</class>
                          <class>org.jbpm.persistence.processinstance.ProcessInstanceEventInfo</class>
                          <class>org.drools.persistence.processinstance.WorkItemInfo</class>
                              <properties>
                                    <property name="hibernate.dialect" value="org.hibernate.dialect.Oracle10gDialect" />
                                    <property name="hibernate.connection.driver_class" value="oracle.jdbc.driver.OracleDriver" />
                                     <property name="hibernate.connection.url"
                                              value="jdbc:oracle:thin:@mypc:port:mydb" />
                                   <property name="hibernate.connection.username" value="jbpm" />
                                  <property name="hibernate.connection.password" value="jbpm" />
                                    <property name="hibernate.connection.autocommit" value="false" />
                                   <property name="hibernate.max_fetch_depth" value="3" />
                                   <property name="hibernate.hbm2ddl.auto" value="create" />
                                    <property name="hibernate.show_sql" value="true" />
                         </properties>
                </persistence-unit>
      </persistence>
      
      

       

      However, after executing:

       

      emf = Persistence.createEntityManagerFactory("org.mycompany.task");

       

      Only some of the tables are being created! for example, Attachement and Deadline were not created.

       

      For now - I created them manually but am afraid that it's a bug.