3 Replies Latest reply on Jan 14, 2011 6:21 AM by Michael Burman

    Module artifact naming convention

    Tom Fennelly Master

      At the moment we're naming all artifacts with <groupId>org.switchyard</groupId> e.g. for the core api:




      For the components we were thinking of applying a prefix of "component-" to all the artifactIds e.g. for the bean component:




      So there's no real logical separation between the core and component artifacts.  In the maven repo they'd all be on the same level and the only way of telling the components apart would be from the prefix.  No big deal I suppose.


      We're also toying with the idea of using a sub-groupId of "components" for the components and dropping the prefix.  So the bean component would be:




      I personally prefer this because it highlights the grouping within the <groupId>, which seem more logic to me anyway.  It also means that the will be grouped physically in the maven repo in a sub-folder under switchyard called "components", which I think is nice too.


      Anyone have any major preferences here?