2 Replies Latest reply on Jan 13, 2011 9:00 AM by Jamie S

    JBoss AS 6: MDB awaiting topic/queue creation

    Jamie S Newbie

      Hi, I am trying to piece together a MDB using the @MessageDriven annotation, using stuff from the EJB3 in Action book.

      I am attempting to get this going on JBoss AS 6.0.0 Final, default configuration.

       

      I have read that using the MessageDriven annotation, the destination queue will be created if it does not exist.

      (eg., http://docs.jboss.org/jbossas/docs/Server_Configuration_Guide/4/html/EJB3_Services-Message_Driven_Beans.html )

       

      Here is my annotation:

       

      @MessageDriven(

              name="ShippingRequestProcessor",

              mappedName="queue/ShippingRequestQueue",

              activationConfig = {

                      @ActivationConfigProperty(propertyName = "destinationType", propertyValue = "javax.jms.Queue"),

                      @ActivationConfigProperty(propertyName = "destination", propertyValue = "queue/ShippingRequestQueue"), 

                      })

      public class ShippingRequestProcessor implements MessageListener {

          @PostConstruct

          public void initialize()

          {

              log.info("Shipper initialized.");

          }

       

            public void onMessage(Message message) {

          etc...

       

      Using eclipse, I have created that inside an EJB project, inside an EAR project.

      (The mappedName anno property is added by eclipse / new Message Driven Bean)

       

      When I deploy, my other EJBs get deployed. However, when the MDB 'starts', I see the following in the log:

       

      16:00:11,482 INFO  [org.hornetq.ra.inflow.HornetQActivation] Attempting to reconnect org.hornetq.ra.inflow.HornetQActivationSpec(ra=org.hornetq.ra.HornetQResourceAdapter@3b59640d destination=queue/ShippingRequestQueue destinationType=javax.jms.Queue ack=Auto-acknowledge durable=false clientID=null user=null maxSession=15)

      16:00:11,496 INFO  [org.hornetq.ra.inflow.HornetQActivation] awaiting topic/queue creation queue/ShippingRequestQueue

       

      These two messages are repeated 10 times, and then nothing happens.  initialize() is not called.

      The client indicates the queue is not bound.

       

      Using "jms/ShippingRequestQueue" or "jms.queue.ShippingRequestQueue" does not help, either.

       

       

       

      What am I missing?

       

      Thanks for any help!