1 Reply Latest reply on Jan 16, 2011 3:16 AM by jaikiran pai

    jboss-6.0.0.Final hangs on mac osx 10.6.6

    ejaz ahmed syed Newbie

      JBoss AS 6.0.0

      OS : Mac OS X 10.6.6

      Java JDK : 1.6.0


      Copied "mysql-connector-java-5.0.8.jar" to "$JBOSS_HOME/server/default/lib"

      Execution : $JBOSS_HOME/bin/run.sh


      From the logs it appears that the start up sequence gets stuck  and unable to bring up the http://localhost:8080/admin-console/login.seam , the page just keeps spinning "waiting for localhost"


      01:59:26,174 INFO  [org.apache.coyote.ajp.AjpProtocol] Starting Coyote AJP/1.3 on ajp-

      01:59:26,175 INFO  [org.jboss.bootstrap.impl.base.server.AbstractServer] JBossAS [6.0.0.Final "Neo"] Started in 38s:722ms


      02:05:18,127 INFO  [org.jboss.web.tomcat.service.deployers.TomcatDeployment] deploy, ctxPath=/admin-console

      02:05:18,293 INFO  [org.apache.catalina.core.StandardContext] The listener "com.sun.faces.config.ConfigureListener" is already configured for this context. The duplicate definition has been ignored.

      02:05:18,507 INFO  [javax.enterprise.resource.webcontainer.jsf.config] Initializing Mojarra 2.0.3 ( b05) for context '/admin-console'

      2011-01-16 02:05:23.140 java[3383:903] Apple AWT Startup Exception : *** -[NSCFString appendString:]: nil argument

      2011-01-16 02:05:23.159 java[3383:903] Apple AWT Restarting Native Event Thread


      This is happening on fresh install with no projects deployed in the container. The last 2 lines look suspicious but cannot find anything to give insight on any forums. Can some one share the resolution / thoughts if they have come across similar issue ?