2 Replies Latest reply on Jun 7, 2011 4:20 AM by Heiner Lamprecht

    Web Service deployment failed after JSF update

    Heiner Lamprecht Newbie

      Hi,

       

      I have a problem with deployment of EJB3 web service after upgrading JSF.  IMHO, these two things should not be linked to each other, but reality has a different opinion .

       

      I'm running JBoss AS 5.1.0 GA and updated JSF to 2.0 (Mojarra 2.0.3).  Deploying any WAR works perfect, but when I deploy a JAR package containing a web sevice, I get the following error:

       

      Exception sending context initialized event to listener instance of class org.jboss.web.jsf.integration.config.JBossJSFConfigureListener

      com.sun.faces.config.ConfigurationException: no web.xml present

       

      Well, thats right.  There is no web.xml, as there must not be a web.xml in a JAR file.  Unfortunately, it prevents my complete EJB-package from beeing deployed and started.  I tried to add an empty web.xml file.  As a result, I didn't get any error message, but the application is still not started, web service not initialized, ...

       

      Is there any workaround possible?

       

      Best regards,

       

      Heiner