4 Replies Latest reply on Feb 1, 2011 5:05 AM by henk de boer

    Issue in CR1 visual editor

    henk de boer Master

      I'm using the JBoss tools visual editor (richfaces) on Eclipse 3.6.1 using JBoss tools 3.2 CR1 on Mac OS X 10.6 64 bits.

       

      I encountered a few small oddities. First of all, after I upgraded from Beta 2 and let Eclipse restart, I opened an .xhtml page and got an editor with no tabs. In this editor, tag completion worked, but I could not navigate into a tag. I checked the name of the editor was "JBoss Tools HTML Editor".

       

      When I restarted Eclipse this morning, I suddenly got a slightly different look in the editor. This time there were tabs. I verified the name was still the same and it was. This is what the tabs look like:

       

      osx64_visual_editor.png

      This is by itself correct. Xulrunner and 64 bits just don't work together (except on Linux) and the fact that the editor now starts is perfect. But I wonder why the first time I didn't had these tabs and after the second restart they suddenly were there.

       

      A few small things to consider here:

       

      • Since Visual/Source and Preview is not available, it might be better to have Source as the default for this platform.
      • The message is not really informative. It's just the exception message. I foresee a lot of support questions from users that might be prevented by having a clear message here.
      • There is a link to the faq at the bottom, but it does not lead to any info about this situation.

       

      Also strangely enough, I'm now able to navigate into tags, something I wasn't able to do before the second restart.