0 Replies Latest reply on Jan 31, 2011 10:08 AM by tuishimi

    Running external app from JBOSS app?

    tuishimi Newbie

      I have a RAILS app running inside of JBOSS.

       

      Using RAILS and ActiveRecord to upload large files is slow and timeouts occur.

       

      I decided to [try and] use sqlldr to push these large files to the oracle database.

       

      What works fine:

       

      1. I can generate my upload file in a public folder under the app.

      2. I can generate a valid sqlldr command string.

       

      What doesn't work:

       

      1. No files can be written BY sqlldr to the my web application folders.

       

      This must be a permission problem?  But I run JBOSS (local development) under my own account.  If I run the same generated command from IRB or even just from the Windows cmd prompt it works like a charm.  But it does not even generate a log file when run from the "system" command.  The error that the ruby system command gives is a cryptic integer value that can mean a variety of things.  The return value is a simple "false" indicating failure.

       

      So I guess my question is:

       

      Has anyone done something like this successfully?  And can it be done?

       

      Thank you for any help or pointers.