6 Replies Latest reply on Feb 9, 2011 1:29 AM by Max Rydahl Andersen

    JBoss-Tools and Eclipse 3.6.1

    vvenkata Newbie

      I am trying to install JBoSS-Tool plugins for Eclipse JEE Helios 3.6.1 and I am not able to do it as per the instructions given in the

      https://www.jboss.org/tools/download/installation/update_3_2.html#fromzip

       

       

      here is what i have tried so far.

       

      I am runing FC6 on my desktop.

       

      I have eclipse installed at ~/jboss/eclipse directory.

      As per the instructions, I downloaded the zip files from JBoSS-Tools. I unzipped them in ~/jboss. So I have plugins and features directory in the parent directory where eclipse is installed. Now when I stop eclipse and restart eclipse with the -clean option, I don't see the plugins.

       

      So I tried to leave the zip files as such in ~/jboss/jboss_plugins directory and then tried to add them through the "Install new software" option in Help menu. When I try to specify the location of the directory in the archive file, it seems to select the individual zip file and doesn't let me add the plugins.

       

      Can anyone help me. Is there a incompatibility between the eclipse helios version and the version of jboss-tools that i have downloaded?

       

      Thanks,

      V.V.chalam

        • 1. JBoss-Tools and Eclipse 3.6.1
          Snjezana Peco Master

          You should download an archived update site. JBoos Tools 3.2.0.CR1 is placed on

          http://download.jboss.org/jbosstools/builds/development/3.2.0.CR1/sf.net/jbosstools-3.2.0.CR1.aggregate-Update-2011-01-23_08-34-59-H190.zip

           

          Check if the download is successful. The size of the downloaded file should be 173,225,467 bytes. Recently there is a problem with the sourceforge site so there is a possibilty you haven't downloaded the complete file.

           

          You don't need to unzip it, but call Help>Install New Software>Add>Local and point to the zip file you downloaded.

           

          If you want to install the JBoss Maven Integration, JBoss BIRT Integration and JBoss TPTP, you also need to install m2eclipse-core 0.12.x, m2eclipse-wtp 0.11.1, BIRT  and TPTP runtimes.

          M2eclipse can be installed only using the following update sites:

          http://m2eclipse.sonatype.org/sites/m2e/

          http://m2eclipse.sonatype.org/sites/m2e-extras/

           

          BIRT and TPTP can be downloaded from:

          http://www.eclipse.org/birt

          http://www.eclipse.org/tptp

           

          If you want to install JBoss Tools to the dropins directory, you can create a script like the following:

           

          <ECLIPSE_HOME>\eclipse.exe -nosplash -consolelog -application org.eclipse.equinox.p2.repository.repo2runnable -source  file:///<YOUR_DIRECTORY>jbosstools-3.2.0.CR1.aggregate-Update-2011-01-23_08-34-59-H190.zip C:\jbosstools

          on Windows (YOUR_DIRECTORY looks like C:/downloads, not C:\downloads)

          or

          <ECLIPSE_HOME>/eclipse -nosplash -consolelog -application org.eclipse.equinox.p2.repository.repo2runnable -source  file:///<YOUR_DIRECTORY>/jbosstools-3.2.0.CR1.aggregate-Update-2011-01-23_08-34-59-H190.zip ~/jbosstools

          on Linux.

           

          JBoss Tools features and plugins will be placed in the jbosstools directory. Copy the features and plugins directory to <ECLIPSE_HOME>/dropins/jbosstools/eclipse and restart Eclipse.

          • 2. JBoss-Tools and Eclipse 3.6.1
            vvenkata Newbie

            Thanks Snjezana, this ZIP for the JBOSS-Tools works.

            • 3. JBoss-Tools and Eclipse 3.6.1
              Rick Herrick Newbie

              Snjezana, I'm having an issue installing JBoss Tools 3.2.0.CR1 as well, although my situation is kind of weird. The machine is running SpringSource Tool Suite 2.5.1 (Eclipse 3.6.1) on an isolated network with no internet access, so I copied over the site archive on a flash drive. When I try to install, I get the following error:

              Cannot complete the install because one or more required items could not be found.

                Software being installed: JBoss ESB Tools 1.3.0.v20110123-0205-H14-CR1 (org.jboss.tools.esb.feature.feature.group 1.3.0.v20110123-0205-H14-CR1)

                Missing requirement: JBoss ESB Project UI Plugin 1.4.0.v20110123-0205-H14-CR1 (org.jboss.tools.esb.project.ui 1.4.0.v20110123-0205-H14-CR1) requires 'bundle org.eclipse.jst.ws.annotations.core 0.0.0' but it could not be found

                Cannot satisfy dependency:

                  From: JBoss ESB Tools 1.3.0.v20110123-0205-H14-CR1 (org.jboss.tools.esb.feature.feature.group 1.3.0.v20110123-0205-H14-CR1)

               

                  To: org.jboss.tools.esb.project.ui [1.4.0.v20110123-0205-H14-CR1]

               

              I do have org.eclipse.jst.ws.annotations.core installed, of course:

               

               

              • org.eclipse.jst.common.annotations.controller_1.1.300.v200908252030.jar
              • org.eclipse.jst.common.annotations.core_1.1.300.v201004141630.jar
              • org.eclipse.jst.common.annotations.ui_1.1.300.v201002081900.jar

               

              I tried to manually force the version to work, but I can't find any kind of manifest in the site archive that indicates that that's a dependency or where the version is specified as 0.0.0, so that didn't help.

               

              I found this post and tried to create a version I could just place in drop-ins. I ran the following command:

               

              \SpringSource\sts-2.5.1.RELEASE\STS.exe -nosplash -consolelog -application org.eclipse.equinox.p2.repository.repo2runnable -source file:///c:/users/myname/downloads/jbosstools-3.2.0.CR1.aggregate-Update-2011-01-23_08-34-59-H190.zip c:/Users/myname/Downloads/JBossTools

               

              The result of this was the stuff at the bottom where you see "LOG STARTS HERE".  The key bit is this: "Unable to locate a valid destination repository."  I changed the end from C:\Users\myname\Downloads\JBossTools to using the '/', same result, created the folder manually before running the command, same result.

               

              I really need to get this installed, but I'm totally stumped.  Neither the site archive nor drop-in conversion process is working.  Any help would be HUGELY appreciated.

               

              Thanks!

               

              --- LOG STARTS HERE ---

               

              !SESSION 2011-02-08 16:16:47.580 -----------------------------------------------

              eclipse.buildId=2.5.1.201011111000-RELEASE

              java.version=1.6.0_21

              java.vendor=Sun Microsystems Inc.

              BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US

              Framework arguments:  -product com.springsource.sts.ide -application org.eclipse.equinox.p2.repository.repo2runnable -source file:///c:/users/rherrick/downloads/jbosstools-3.2.0.CR1.aggregate-Update-2011-01-23_08-34-59-H190.zip c:/Users/rherrick/Downloads/JBossTools

              Command-line arguments:  -os win32 -ws win32 -arch x86_64 -product com.springsource.sts.ide -consolelog -application org.eclipse.equinox.p2.repository.repo2runnable -source file:///c:/users/rherrick/downloads/jbosstools-3.2.0.CR1.aggregate-Update-2011-01-23_08-34-59-H190.zip c:/Users/rherrick/Downloads/JBossTools

               

               

              !ENTRY org.eclipse.osgi 4 0 2011-02-08 16:16:52.676

              !MESSAGE Application error

              !STACK 1

              org.eclipse.equinox.p2.core.ProvisionException: Unable to locate a valid destination repository.

                        at org.eclipse.equinox.p2.internal.repository.tools.AbstractApplication.processDestinationRepos(AbstractApplication.java:169)

                        at org.eclipse.equinox.p2.internal.repository.tools.AbstractApplication.initializeRepos(AbstractApplication.java:133)

                        at org.eclipse.equinox.p2.internal.repository.tools.Repo2Runnable.run(Repo2Runnable.java:114)

                        at org.eclipse.equinox.p2.internal.repository.tools.Repo2Runnable.start(Repo2Runnable.java:239)

                        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)

                        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)

                        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)

                        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)

                        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)

                        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

                        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

                        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

                        at java.lang.reflect.Method.invoke(Method.java:597)

                        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)

                        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)

                        at org.eclipse.equinox.launcher.Main.run(Main.java:1407)

                        at org.eclipse.equinox.launcher.Main.main(Main.java:1383)

              • 4. JBoss-Tools and Eclipse 3.6.1
                Rick Herrick Newbie

                I just realized I don't have org.eclipse.jst.ws.annotations.core installed. Those are org.eclipse.jst.common.annotations packages. Doh.

                • 5. JBoss-Tools and Eclipse 3.6.1
                  Rick Herrick Newbie

                  I downloaded and installed the JST SDK from here:

                   

                  http://download.eclipse.org/webtools/downloads/drops/R3.2.0/R-3.2.0-20100615235519/

                   

                  That gave me the required dependency to install JBoss Tools successfully.

                  • 6. JBoss-Tools and Eclipse 3.6.1
                    Max Rydahl Andersen Master

                    Rick, I assume the only reason that didn't get installed by default was that you A) was not connected to the network and/or B) your eclipse installaiton did not include the WST parts from WTP.

                     

                    Unfortunate that p2 isn't really good at giving sensible errors ;(