1 Reply Latest reply on Feb 5, 2011 1:13 PM by Ron Sigal

    Help!!! ON Jboss and IIS 6 ISAPI

    Victor Usamah Newbie

      Please i need a huge favour from any Jboss IIS User and idea that could help will be appreciated cos...i have been trying to redirect request from IIS to an EAR (homepage.ear) file delpoyed in Jboss-5.1.0.GA in the deploy folder. And i have been on this for months and all efforts have be notting ur contribution is required Thanks.


      I can not access my application via this url but i can access it via


      i what to resolve the port 8080


      i have congifured the followings WITH THIS TOOL:


      1 Web Server – IIS version: 6

      2 Application Server – JBoss-5.1.0.GA


      3 Java Development Kit – J2SE Development Kit 5.0 Update 7

      4 ISAPI Redirector 1.2.30.DLL

      5 Operating System – Windows Server 2003 with SP2:


      Ear file in this path C:\jboss-5.1.0.GA\server\ default\deploy


      Installed isapi_redirect-1.2.14.exe in this path C:\Jakarta Isapi Redirector\jboss_tomcat    and it created a Registry on my PC as shown below


      Key Name:          HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Jakarta Isapi Redirector\1.0

      Class Name:        <NO CLASS>

      Last Write Time:   2/3/2011 - 2:32 PM

      Value 0

        Name:            <NO NAME>

        Type:            REG_SZ



      Value 1

        Name:            extension_uri

        Type:            REG_SZ

        Data:            /jakarta/isapi_redirect.dll


      Value 2

        Name:            log_file

        Type:            REG_SZ

        Data:            C:\Jakarta Isapi Redirector\jboss_tomcat\log\isapi_redirect.log


      Value 3

        Name:            log_level

        Type:            REG_SZ

        Data:            info


      Value 4

        Name:            worker_file

        Type:            REG_SZ

        Data:            C:\Jakarta Isapi Redirector\jboss_tomcat\conf\workers.properties.minimal


      Value 5

        Name:            worker_mount_file

        Type:            REG_SZ

        Data:            C:\Jakarta Isapi Redirector\jboss_tomcat\conf\uriworkermap.properties


      I downloaded isapi_redirect-1.2.30.dll    renamed it to isapi_redirect.dll and replaced the on in my bin folder


      C:\Jakarta Isapi Redirector\jboss_tomcat\bin


      I modify workers.properties.minimal to workers.properties and droped my workers.properties file in the config


      C:\Jakarta Isapi Redirector\jboss_tomcat\conf


      WORKER.PROPERTIES configuration as follows:


      # workers.properties.minimal -


      # This file provides minimal jk configuration properties needed to

      # connect to Tomcat.


      # The workers that jk should create and work with






      # Defining a worker named ajp13w and of type ajp13

      # Note that the name and the type do not have to match.

      # Define node1

















      # Defining a load balancer



      # Defining a template worker to be used






      # Define Node1

      # modify the host as your host IP or DNS name.







      # Load-balancing worker






      # Define status worker







      # uriworkermap.properties - IIS


      # This file provides sample mappings for example wlb

      # worker defined in workermap.properties.minimal

      # The general syntax for this file is:

      # [URL]=[Worker name]







      #send all /homepage requests to node1





      # Optionally filter out all .jpeg files inside that context

      # For no mapping the url has to start with exclamation





      # Mount jkstatus to /jkmanager

      # For production servers you will need to

      # secure the access to the /jkmanager url




      CONFIGURED IIS 6 AND isapi_redirect.dll AS FOLLOWS



      Open IIS Manager  navigate to (local computer)  >>> Web Sites>>>> right click on “Default Web Site” click on properties,


      from the properties windows click on “ISAPI filters” tab click “Add” give filter name as “jakarta” (exact spelling & case required),


      add Executable path as


      C:\Jakarta Isapi Redirector\jboss_tomcat\bin\isapi_redirect.dll” apply the changes and clicked ok. 


      I right click on the “Default Web Site” and create a “virtual directory” named “jakarta” (exact spelling & case) and set the path to


      C:\Jakarta Isapi Redirector\jboss_tomcat\bin\isapi_redirect.dll


      Gave Read, Run Scripts and Execute permissions during the creation of virtual directory “jakarta”


      Then navigate to Web Service Extensions from IIS Manager and right click on the right pane of the IIS Manager and 


      click “Add a new Web service extension…” and create the extension named “jakarta” (exact spelling & case) with “Required Files” path to


      C:\Jakarta Isapi Redirector\jboss_tomcat\bin\isapi_redirect.dll” and set the extension statusto “Allowed”.


      I Copied my ear into this path “C:\Inetpub\wwwroot” 


      or sometime i set the default directry from IIS to the path where my EAR file is deployed


      C:\jboss-5.1.0.GA\server\ default\deploy


      And restart all services including my pc





      ISAPI does not generated logfile in the log directory so i can trace my error


      some times the ISAPI do not show green arrow upward and if it shows it does not display it's priority whether high or low


      some times if the ISAPI priority is high and i try to access this url  is dose not display it show error 404


      but i can always access  i need to resolve the port...





      Please is the any configuration and missing out or doing wrong....


      Do i need to do any settings in JBOSS Config files or service xml do need to add or remove pls advice


      i appreciate your great help hope to get a feedback soon