6 Replies Latest reply on Feb 7, 2011 11:58 AM by Gary Brown

    Unsuccesful SOAP(REST) calls

    Igor JStarter Novice

      Hey Gary!

       

      Sorry to interupt.. I've got one question...

       

      I use a partner SMS gateway who has exposed a REST service for sending SMS... I've developed a soap ws which i'm able to call from riftsaw and that service calls the rest sms service...

       

      When calling my soap service (which calls sms rest - deployed with axis2 on same jboss as) from SoapUI the message always sends well.

      But when i call it from riftsaw or 90% it doesn't send... An get a 400 error message...

       

      Do you now where could be the problem or tell me where is the difference in a soapui and riftsaw client???

       

      Thank you very much!

       

      Regards, Igor!

        • 1. Unsuccesful SOAP(REST) calls
          Gary Brown Master

          There should be no difference, so not sure what could be causing this. Only thing I can suggest is to check the server log for any relevant error messages and put on finest level of debug/tracing to see if there is anything obviously different about the messages.

          • 2. Unsuccesful SOAP(REST) calls
            Igor JStarter Novice

            Up to now there is no additional log data... When trying it with SoapUI, I get the response 200 very quick.

            When trying with Riftsaw, I get:

            13:39:27,460 ERROR [STDERR]java.io.IOException: Server returned HTTP response code: 400 for URL: http://212.235.xxx.xx/rtvfw/unifiedsender/sendsmsdispatcher.aspx?dest=1954306&sms=miskaaaaaaaaaaadelamooo&service_keyword=IDC-0479&apikey=zNjM2Q0ODZjM

            13:39:27,460 ERROR [STDERR]     at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1313)

            13:39:27,461 ERROR [STDERR]     atLtfeSMS.sendSMS(LtfeSMS.java:57)

            13:39:27,461 ERROR [STDERR]     atsun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

            13:39:27,461 ERROR [STDERR]     atsun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

            13:39:27,461 ERROR [STDERR]     atsun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

            13:39:27,461 ERROR [STDERR]     at java.lang.reflect.Method.invoke(Method.java:597)

            13:39:27,461 ERROR [STDERR]     atorg.apache.axis2.rpc.receivers.RPCUtil.invokeServiceClass(RPCUtil.java:194)

            13:39:27,461 ERROR [STDERR]     atorg.apache.axis2.rpc.receivers.RPCMessageReceiver.invokeBusinessLogic(RPCMessageReceiver.java:102)

            13:39:27,461 ERROR [STDERR]     atorg.apache.axis2.receivers.AbstractInOutMessageReceiver.invokeBusinessLogic(AbstractInOutMessageReceiver.java:40)

            13:39:27,461 ERROR [STDERR]     atorg.apache.axis2.receivers.AbstractMessageReceiver.receive(AbstractMessageReceiver.java:114)

            13:39:27,461 ERROR [STDERR]     atorg.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:173)

            13:39:27,462 ERROR [STDERR]     atorg.apache.axis2.transport.http.HTTPTransportUtils.processHTTPPostRequest(HTTPTransportUtils.java:173)

            13:39:27,462 ERROR [STDERR]     atorg.apache.axis2.transport.http.AxisServlet.doPost(AxisServlet.java:142)

            13:39:27,462 ERROR [STDERR]     atjavax.servlet.http.HttpServlet.service(HttpServlet.java:637)

            13:39:27,462 ERROR [STDERR]     atjavax.servlet.http.HttpServlet.service(HttpServlet.java:717)

            13:39:27,462 ERROR [STDERR]     atorg.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)

            13:39:27,462 ERROR [STDERR]     at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)

            13:39:27,462 ERROR [STDERR]     atorg.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)

            13:39:27,462 ERROR [STDERR]     atorg.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)

            13:39:27,462 ERROR [STDERR]     atorg.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)

            13:39:27,462 ERROR [STDERR]     atorg.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:235)

            13:39:27,462 ERROR [STDERR]     atorg.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)

            13:39:27,463 ERROR [STDERR]     atorg.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:190)

            13:39:27,463 ERROR [STDERR]     atorg.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:92)

            13:39:27,463 ERROR [STDERR]     atorg.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)

            13:39:27,463 ERROR [STDERR]     atorg.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)

            13:39:27,463 ERROR [STDERR]     at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)

            13:39:27,463 ERROR [STDERR]     atorg.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)

            13:39:27,463 ERROR [STDERR]     atorg.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)

            13:39:27,463 ERROR [STDERR]     atorg.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)

            13:39:27,463 ERROR [STDERR]     atorg.apache.coyote.http11.Http11Processor.process(Http11Processor.java:829)

            13:39:27,463 ERROR [STDERR]     atorg.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:598)

            13:39:27,463 ERROR [STDERR]     atorg.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)

            13:39:27,464 ERROR [STDERR]     atjava.lang.Thread.run(Thread.java:619)

             

            I'm trying now to write a second WS... because i don't have any other idea ...

            I think there is a problem waiting for responses... time related...


            Because I couldn't send neither 1 sms. But then I put into the script about 30 printlines....

            and suddenly the first sms was succesfully send... Others not

            • 3. Unsuccesful SOAP(REST) calls
              Igor JStarter Novice

              Now I'm confused... after including some logging i see:

              2011-02-07 15:26:34,535 TRACE [org.jboss.ws.core.MessageTrace] (ODEServer-4) Outgoing Request Message

              <env:Envelope xmlns:env='http://schemas.xmlsoap.org/soap/envelope/'>

              <env:Header/>

              <env:Body>

                <sendSMS xmlns='http://ws.apache.org/axis2'>

                 <ns:args0 xmlns:ns='http://ws.apache.org/axis2'>38641616089</ns:args0>

                 <ns:args1 xmlns:ns='http://ws.apache.org/axis2'>miskaaaaaaaaaaa delamooo</ns:args1>

                </sendSMS>

              </env:Body>

              </env:Envelope>

              2011-02-07 15:26:34,536 TRACE [org.jboss.ws.core.CommonMessageContext] (ODEServer-4) get(org.jboss.ws.DOMContentCanonicalNormalization): null

              2011-02-07 15:26:34,536 TRACE [org.jboss.ws.core.soap.SOAPContentElement] (ODEServer-4) getChildNodes

              2011-02-07 15:26:34,537 TRACE [org.jboss.ws.core.soap.SOAPContentElement] (ODEServer-4) getChildNodes

              2011-02-07 15:26:34,632 TRACE [org.jboss.ws.core.soap.SOAPMessageUnMarshallerHTTP] (ODEServer-4) Read input stream with metadata={org.jboss.ws.core.client.transport.NettyClient#Protocol=HTTP/1.1, org.jboss.ws.core.client.transport.NettyClient#ResponseCodeMessage=OK, org.jboss.ws.core.client.transport.NettyClient#ResponseCode=200}

              2011-02-07 15:26:34,633 TRACE [org.jboss.ws.core.soap.MessageFactoryImpl] (ODEServer-4) [Date=Mon, 07 Feb 2011 14:26:34 GMT]

              2011-02-07 15:26:34,633 TRACE [org.jboss.ws.core.soap.MessageFactoryImpl] (ODEServer-4) [Content-Length=266]

              2011-02-07 15:26:34,633 TRACE [org.jboss.ws.core.soap.MessageFactoryImpl] (ODEServer-4) [Content-Type=text/xml;charset=UTF-8]

              2011-02-07 15:26:34,633 TRACE [org.jboss.ws.core.soap.MessageFactoryImpl] (ODEServer-4) [X-Powered-By=Servlet 2.5; JBoss-5.0/JBossWeb-2.1]

              2011-02-07 15:26:34,633 TRACE [org.jboss.ws.core.soap.MessageFactoryImpl] (ODEServer-4) [Server=Apache-Coyote/1.1]

              2011-02-07 15:26:34,633 DEBUG [org.jboss.ws.core.soap.MessageFactoryImpl] (ODEServer-4) createMessage: [contentType=text/xml; charset=UTF-8]

              2011-02-07 15:26:34,633 TRACE [org.jboss.ws.core.soap.MessageFactoryImpl] (ODEServer-4) createMessage

              <?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Body><ns:sendSMSResponse xmlns:ns="http://ws.apache.org/axis2"><ns:return>-1</ns:return></ns:sendSMSResponse></soapenv:Body></soapenv:Envelope>

              2011-02-07 15:26:34,634 TRACE [org.jboss.ws.core.soap.MessageFactoryImpl] (ODEServer-4) Using style: document

              2011-02-07 15:26:34,635 TRACE [org.jboss.wsf.common.DOMUtils] (ODEServer-4) createElement {http://schemas.xmlsoap.org/soap/envelope/}soapenv:Envelope

              2011-02-07 15:26:34,635 TRACE [org.jboss.wsf.common.DOMUtils] (ODEServer-4) createElement {http://schemas.xmlsoap.org/soap/envelope/}soapenv:Body

              2011-02-07 15:26:34,635 TRACE [org.jboss.wsf.common.DOMUtils] (ODEServer-4) createElement {http://ws.apache.org/axis2}ns:sendSMSResponse

              2011-02-07 15:26:34,636 TRACE [org.jboss.ws.core.soap.SOAPContentElement] (ODEServer-4) addNamespaceDeclaration: [prefix=ns,nsURI=http://ws.apache.org/axis2]

              2011-02-07 15:26:34,636 TRACE [org.jboss.ws.core.soap.SOAPContentElement] (ODEServer-4) setAttribute: [nsURI=http://www.w3.org/2000/xmlns/,name=xmlns:ns,value=http://ws.apache.org/axis2]

              2011-02-07 15:26:34,637 TRACE [org.jboss.ws.core.MessageTrace] (ODEServer-4) Incoming Response Message

              <soapenv:Envelope xmlns:soapenv='http://schemas.xmlsoap.org/soap/envelope/'>

              <soapenv:Body>

                <ns:sendSMSResponse xmlns:ns='http://ws.apache.org/axis2'>

                 <ns:return>-1</ns:return>

                </ns:sendSMSResponse>

              </soapenv:Body>

              </soapenv:Envelope>

              2011-02-07 15:26:34,637 DEBUG [org.jboss.ws.core.jaxws.handler.MessageContextJAXWS] (ODEServer-4) Begin response processing

              2011-02-07 15:26:34,637 TRACE [org.jboss.ws.core.CommonMessageContext] (ODEServer-4) get(javax.xml.ws.handler.message.outbound): APPLICATION:javax.xml.ws.handler.message.outbound=true

              2011-02-07 15:26:34,637 DEBUG [org.jboss.ws.core.soap.MessageContextAssociation] (ODEServer-4) popMessageContext: org.jboss.ws.core.jaxws.handler.SOAPMessageContextJAXWS@d871 (Thread ODEServer-4)

              2011-02-07 15:26:34,638 TRACE [org.jboss.ws.core.CommonMessageContext] (ODEServer-4) put: APPLICATION:javax.xml.ws.handler.message.outbound=false

              2011-02-07 15:26:34,638 DEBUG [org.jboss.ws.core.soap.MessageContextAssociation] (ODEServer-4) pushMessageContext: org.jboss.ws.core.jaxws.handler.SOAPMessageContextJAXWS@1ca2d9a (Thread ODEServer-4)

              2011-02-07 15:26:34,638 TRACE [org.jboss.ws.core.CommonMessageContext] (ODEServer-4) get(javax.xml.ws.handler.message.outbound): APPLICATION:javax.xml.ws.handler.message.outbound=false

              2011-02-07 15:26:34,638 TRACE [org.jboss.ws.core.CommonMessageContext] (ODEServer-4) get(javax.xml.ws.handler.message.outbound): APPLICATION:javax.xml.ws.handler.message.outbound=false

              2011-02-07 15:26:34,638 TRACE [org.jboss.ws.core.CommonMessageContext] (ODEServer-4) get(javax.xml.ws.handler.message.outbound): APPLICATION:javax.xml.ws.handler.message.outbound=false

              2011-02-07 15:26:34,638 DEBUG [org.jboss.ws.core.jaxws.handler.HandlerChainExecutor] (ODEServer-4) close

              2011-02-07 15:26:34,638 DEBUG [org.jboss.ws.core.jaxws.handler.HandlerChainExecutor] (ODEServer-4) close

              2011-02-07 15:26:34,638 DEBUG [org.jboss.ws.core.jaxws.handler.HandlerChainExecutor] (ODEServer-4) close

              2011-02-07 15:26:34,638 DEBUG [org.jboss.ws.core.soap.MessageContextAssociation] (ODEServer-4) popMessageContext: org.jboss.ws.core.jaxws.handler.SOAPMessageContextJAXWS@1ca2d9a (Thread ODEServer-4)

              2011-02-07 15:26:34,639 DEBUG [org.jboss.soa.bpel.runtime.ws.WebServiceClient] (ODEServer-4) Riftsaw soap response message:

              <soapenv:Envelope xmlns:soapenv='http://schemas.xmlsoap.org/soap/envelope/'><soapenv:Body><ns:sendSMSResponse xmlns:ns='http://ws.apache.org/axis2'><ns:return>-1</ns:return></ns:sendSMSResponse></soapenv:Body></soapenv:Envelope>

              2011-02-07 15:26:34,639 TRACE [org.jboss.ws.core.soap.SOAPContentElement] (ODEServer-4) getFirstChild

              2011-02-07 15:26:34,639 DEBUG [org.jboss.ws.core.soap.SOAPContentElement] (ODEServer-4) -----------------------------------

              2011-02-07 15:26:34,639 DEBUG [org.jboss.ws.core.soap.SOAPContentElement] (ODEServer-4) Transitioning from XML_VALID to DOM_VALID

              2011-02-07 15:26:34,640 TRACE [org.jboss.ws.core.soap.SOAPContentElement] (ODEServer-4) removeContents

              2011-02-07 15:26:34,640 TRACE [org.jboss.ws.core.soap.SOAPContentElement] (ODEServer-4) getChildElements

              2011-02-07 15:26:34,640 TRACE [org.jboss.ws.core.soap.SOAPContentElement] (ODEServer-4) getChildNodes

              2011-02-07 15:26:34,640 TRACE [org.jboss.ws.core.soap.SOAPContentElement] (ODEServer-4) setAttribute: [nsURI=http://www.w3.org/2000/xmlns/,name=xmlns:ns,value=http://ws.apache.org/axis2]

              2011-02-07 15:26:34,640 TRACE [org.jboss.wsf.common.DOMUtils] (ODEServer-4) createElement {http://ws.apache.org/axis2}ns:return

              2011-02-07 15:26:34,640 TRACE [org.jboss.ws.core.soap.SOAPContentElement] (ODEServer-4) addChildElement: org.jboss.ws.core.soap.SOAPElementImpl@77fd41[[ns:return: null]]

              2011-02-07 15:26:34,640 TRACE [org.jboss.ws.core.soap.SOAPContentElement] (ODEServer-4) appendChild: org.jboss.ws.core.soap.SOAPElementImpl@77fd41[[ns:return: null]]

              2011-02-07 15:26:34,640 DEBUG [org.jboss.ws.core.soap.SOAPContentElement] (ODEServer-4) -----------------------------------

              2011-02-07 15:26:34,651 DEBUG [org.jboss.soa.bpel.runtime.ws.WebServiceClient] (ODEServer-4) ODE inbound message:

              <message>

              <parameters>

                <ns:sendSMSResponse xmlns:ns='http://ws.apache.org/axis2'>

                 <ns:return>-1</ns:return>

                </ns:sendSMSResponse>

              </parameters>

              </message>

               

              but here looks like well done - i see responsecode=200 ???

              the server log stays the same - above post ...

               

              SoapUI is 100% successful, Riftsaw 0%.

               

              btw My java code goes like:

                  private static void request(boolean quiet, URL url, InputStream body)

                  {

                      System.out.println("[issuing request: " + "GET" + " " + url + "]");

                      HttpURLConnection connection;

                      StringBuffer responseBody;

                      try {

                     

                          connection = (HttpURLConnection)url.openConnection();

                          connection.setRequestMethod("GET"); 

                          byte buffer[] = new byte[8192];

                          int read = 0;

                          if (body != null)

                          {

                              connection.setDoOutput(true);          

                              OutputStream output = connection.getOutputStream();

                              while ((read = body.read(buffer)) != -1)

                              {

                                  output.write(buffer, 0, read);

                              }           

                          }

                          // do request

                          long time = System.currentTimeMillis();

                          connection.connect();

                          InputStream responseBodyStream = connection.getInputStream();

                          responseBody = new StringBuffer();

                          while ((read = responseBodyStream.read(buffer)) != -1)

                          {

                              responseBody.append(new String(buffer, 0, read));

                          }

                          connection.disconnect();

                          time = System.currentTimeMillis() - time;

                         

                          // start printing output

                          if (!quiet)

                              System.out.println("[read " + responseBody.length() + " chars in " + time + "ms]");

               

              The last line isn't printing, so the error must be before...

               

              If anybody got an idea, please tell me...

               

              Regards, Igor!

               

              13:39:27,460 ERROR [STDERR] java.io.IOException: Server returned HTTP response code: 400 for URL: http://212.235.185.78/rtvfw/unifiedsender/sendsmsdispatcher.aspx?dest=1954306&sms=miskaaaaaaaaaaa delamooo&service_keyword=IDC-040273929&apikey=ZGMtZGVqYW46OmVhNzJkZmJkYTBiOTJjNzNjM2Q0ODZjMzRiYzk1MjAx
              13:39:27,460 ERROR [STDERR]     at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1313)
              13:39:27,461 ERROR [STDERR]     at LtfeSMS.sendSMS(LtfeSMS.java:57)
              13:39:27,461 ERROR [STDERR]     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              13:39:27,461 ERROR [STDERR]     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
              13:39:27,461 ERROR [STDERR]     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              13:39:27,461 ERROR [STDERR]     at java.lang.reflect.Method.invoke(Method.java:597)
              13:39:27,461 ERROR [STDERR]     at org.apache.axis2.rpc.receivers.RPCUtil.invokeServiceClass(RPCUtil.java:194)
              13:39:27,461 ERROR [STDERR]     at org.apache.axis2.rpc.receivers.RPCMessageReceiver.invokeBusinessLogic(RPCMessageReceiver.java:102)
              13:39:27,461 ERROR [STDERR]     at org.apache.axis2.receivers.AbstractInOutMessageReceiver.invokeBusinessLogic(AbstractInOutMessageReceiver.java:40)
              13:39:27,461 ERROR [STDERR]     at org.apache.axis2.receivers.AbstractMessageReceiver.receive(AbstractMessageReceiver.java:114)
              13:39:27,461 ERROR [STDERR]     at org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:173)
              13:39:27,462 ERROR [STDERR]     at org.apache.axis2.transport.http.HTTPTransportUtils.processHTTPPostRequest(HTTPTransportUtils.java:173)
              13:39:27,462 ERROR [STDERR]     at org.apache.axis2.transport.http.AxisServlet.doPost(AxisServlet.java:142)
              13:39:27,462 ERROR [STDERR]     at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
              13:39:27,462 ERROR [STDERR]     at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
              13:39:27,462 ERROR [STDERR]     at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
              13:39:27,462 ERROR [STDERR]     at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
              13:39:27,462 ERROR [STDERR]     at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
              13:39:27,462 ERROR [STDERR]     at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
              13:39:27,462 ERROR [STDERR]     at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
              13:39:27,462 ERROR [STDERR]     at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:235)
              13:39:27,462 ERROR [STDERR]     at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
              13:39:27,463 ERROR [STDERR]     at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:190)
              13:39:27,463 ERROR [STDERR]     at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:92)
              13:39:27,463 ERROR [STDERR]     at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)
              13:39:27,463 ERROR [STDERR]     at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)
              13:39:27,463 ERROR [STDERR]     at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
              13:39:27,463 ERROR [STDERR]     at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
              13:39:27,463 ERROR [STDERR]     at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
              13:39:27,463 ERROR [STDERR]     at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)
              13:39:27,463 ERROR [STDERR]     at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:829)
              13:39:27,463 ERROR [STDERR]     at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:598)
              13:39:27,463 ERROR [STDERR]     at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
              13:39:27,464 ERROR [STDERR]     at java.lang.Thread.run(Thread.java:619)
              • 4. Unsuccesful SOAP(REST) calls
                Gary Brown Master

                Igor JStarter wrote:


                2011-02-07 15:26:34,640 DEBUG [org.jboss.ws.core.soap.SOAPContentElement] (ODEServer-4) -----------------------------------

                2011-02-07 15:26:34,651 DEBUG [org.jboss.soa.bpel.runtime.ws.WebServiceClient] (ODEServer-4) ODE inbound message:

                <message>

                <parameters>

                  <ns:sendSMSResponse xmlns:ns='http://ws.apache.org/axis2'>

                   <ns:return>-1</ns:return>

                  </ns:sendSMSResponse>

                </parameters>

                </message>

                 

                 

                Sorry Igor, I am confused - what does this response mean? Your BPEL process seems to have communicated with a web service and received a response back?

                • 5. Unsuccesful SOAP(REST) calls
                  Igor JStarter Novice

                  Yes, I'm returning an integer -1 at the end of the code...

                  So it looks like it going through:

                  1. catch (IOexception) - java.io.IOException: Server returned HTTP response code: 400 for UR

                  2. and then returning -1 to RIftsaw

                   

                  The working SoapUI call returns -1 without any exceptions ...

                  • 6. Unsuccesful SOAP(REST) calls
                    Gary Brown Master

                    In which case this is not a RiftSaw issue. Looks like you need to be using the jbossws mailing list?