1 Reply Latest reply on Apr 8, 2011 4:54 AM by Michal Toman

    Queue stops working under load without error

    Michal Glowacki Novice

      hi,

       

           I created queue to put incoming requests into LinkedList, so I can process them one by one. It works perfect, until for example 10 requests come exactly same time. Then my queue just freezes. Any new request is not processed, I can't see any errors in the logs. I have to redeploy my MDB jar file in order to get it working again. However all messages are lost. I checked via JMX console state of the queue when it's broken, everything looks fine, DLQ is empty. Do you know where I could look for an error?

       

      here's jms-destination-service.xml

       

       

      <mbean code="org.jboss.jms.server.destination.QueueService"
              name="jboss.messaging.destination:service=Queue,name=ProcessingQueue"
           xmbean-dd="xmdesc/Queue-xmbean.xml">
       <attribute name="RedeliveryDelay">3000</attribute> <!-- those 2 I added later, but also did not help -->
       <attribute name="MaxDeliveryAttempts">3</attribute>
       <depends optional-attribute-name="ServerPeer">jboss.messaging:service=ServerPeer</depends>
       <depends>jboss.messaging:service=PostOffice</depends>
      </mbean> 
      

       

      and beginning of my MDB class:

       

      @MessageDriven(activationConfig = {
        @ActivationConfigProperty(
        propertyName = "destinationType", propertyValue = "javax.jms.Queue"),
        @ActivationConfigProperty(
        propertyName = "destination", propertyValue = "/queue/ProcessingQueue"),
        @ActivationConfigProperty(
        propertyName = "acknowledgeMode", propertyValue = "Auto-acknowledge")
      })
      @org.jboss.ejb3.annotation.Depends("org.hornetq:module=JMS,name=\"ProcessingQueue\",type=Queue")
      

       

       

       

       

      Thanks,

      Michal

        • 1. Queue stops working under load without error
          Michal Toman Newbie

          It depends, you are talking about the LinkedList. I could guess you are doing some processing in your code. Many custom applications cause the freezing the code of middleware. If it is true, look primarily to your code. This is a common problem that I could guess the problem is somewhere in your Java code. But it is only the tip. Look for sampel at google or give some more details.