0 Replies Latest reply on Feb 19, 2011 9:02 AM by dave rite

    can't change Port for running jboss as - or other problem?

    dave rite Newbie

      Hi,

      I trying to run JBoss AS 5.1 on my mac 10.5. I am running java 6 (1.6) and have set all variables (JBOSS_HOME and (JAVA_HOME).

      when running the run.sh I get the following error:

      12:56:23,244 ERROR [AbstractKernelController] Error installing to Start: name=jboss:service=WebService state=Create mode=Manual requiredState=Installed

      java.lang.Exception: Port 8083 already in use.

      I tried to google solutions and couldn't find anything but actually changing the port. When checking the port 8080

      I find the following services running:

      COMMAND    PID      USER   FD   TYPE    DEVICE SIZE/OFF NODE NAME

      launchd   3418 vassoliki    8u  IPv6 0x6eda984      0t0  TCP *:http-alt (LISTEN)

      launchd   3418 vassoliki   10u  IPv4 0x9ec9270      0t0  TCP *:http-alt (LISTEN)

      printerAg 3546 vassoliki    4u  IPv6 0x6eda984      0t0  TCP *:http-alt (LISTEN)

      printerAg 3546 vassoliki    5u  IPv4 0x9ec9270      0t0  TCP *:http-alt (LISTEN)

      That's obviously the reason why the server tries to connect to port 8083. Weird enough, on this port java is already running

      COMMAND  PID      USER   FD   TYPE    DEVICE SIZE/OFF NODE NAME

      java    1682 vassoliki   75u  IPv6 0x6eda720      0t0  TCP [::127.0.0.1]:us-srv (LISTEN)

      which looks as if already a instance of jboss is running?! how can I stop it?

      I also tried to change the port in different ways:

      when starting: /Users/vassoliki/jboss-5.1.0/bin/run.sh -Djboss.service.binding.set=ports-01 (tried ports+1,-2 etc.). I also checked if the ports 8079 , 8081 are free which they were. I still got the same error message (port 8083 in use), so obviously setting it didn't work.

      I tried to change server xml -> didn't have any effect, and finally I deleted in jboss-service the following line:

      <!-- Get the port to use from ServiceBindingManager. -->

               <value-factory bean="ServiceBindingManager" method="getIntBinding" parameter="jboss:service=WebService"/>


      and set a static value (to 8081). Again, the same error message. I have no clue whatelse to do.....(btw: my firewall is disabled).

       

      thanks for the help!

       

      PS: I attach the whole messages with errors from the terminal