4 Replies Latest reply on Jul 2, 2009 10:17 AM by Manu Osten

    Problem mit a4j:form and rich:tooltip

    Manu Osten Apprentice

      Hello,

      I want that the external tooltip apprears in the datatable, if the mouse is at over the point in the datatable. The external tooltip works only with a4j:form.

      <t:div id="requestTable">
      ..
      ..
      ..
      <rich:dataTable ....>
      ..
      ..
      <rich:column>
      <a4j:outputPanel layout="block">
       <h:graphicImage value="/images/greenBall.png" width="15"
       onmouseover="#{rich:component('tooltipStatusGreen')}.show(event);"
       onmouseout="#{rich:component('tooltipStatusGreen')}.hide(event);" />
      </a4j:outputPanel>
      </rich:column>
      </rich:dataTable>
      <a4j:form id="tooltipform">
      <rich:toolTip id="tooltipStatusGreen" attached="false" value="Sie haben eine Message bekommen." showDelay="300" styleClass="tooltip"/>
      </a4j:form>
      <t:div>
      


      If I call that page from navigationsmenu, the tooltip dont be working. But if I call a4j:commandButton in the page to reload the table and actual the DIV-area id="requestTable", then is the tooltip working.

      I found out the problem of generated the code:

      After the calling the page:

      <div id="j_id_jsp_153693077_1:requestTable">
      <table id="j_id_jsp_153693077_1:j_id_jsp_153693077_94" >
      ...
      </table>
      <span id="j_id_jsp_153693077_1:tooltipform:tooltipStatusGreen" class="dr-rich-tool-tip rich-tool-tip tooltip" style="z-index: 99; visibility: visible; display: none;">
      </div>
      



      After the calling the a4j:commandButton

      <div id="j_id_jsp_153693077_1:requestTable">
      <table id="j_id_jsp_153693077_1:j_id_jsp_153693077_94" >
      ...
      </table>
      <form id="j_id_jsp_153693077_1:tooltipform" name="j_id_jsp_153693077_1:tooltipform" method="post" action="/PonteWeb/anyRequestList.jsf" target="">
      <span id="j_id_jsp_153693077_1:tooltipform:tooltipStatusGreen" class="dr-rich-tool-tip rich-tool-tip tooltip" style="z-index: 99; visibility: visible; display: none;">
      </form>
      </div>
      


      The problem is, that aj4:form isn't generated at the calling the page. Is that bug? Have you an idea to solve that problem?

      Manu