2 Replies Latest reply on Feb 23, 2011 1:51 PM by Nina Check

    richfaces 3.3.3.final source code compile using Netbeans 6.9.1

    Nina Check Newbie

      Hi There,

       

      I would like to build Richfaces 3.3.3.final source code so that I can browse the code to get a deeper understanding of richfaces implementation.  I have downloaded the source and opened the project from the main project pom.xml.  However, I am finding that I have many compilation errors - things as simple as MockDataModel.walk cannot override base walk because base class doesn't throw IOException - even though navigating to the source of the base class clearly shows that the base implementation DOES throw an IOException.

       

      I'm not a newbie developer, but I am new to Maven and dependencies/etc - and I can't seem to figure out why it isn't building.  Each project within the richfaces3.3.3.final src reveals some errors - what am I doing wrong?

       

      Thanks in advance!

        • 1. richfaces 3.3.3.final source code compile using Netbeans 6.9.1
          Jay Balunas Master

          Did you download the source from the distribution or from the svn repo?  You may want to try this from the repo, it may help with some.

           

          There are going to be some compilation errors anyway because of some of the generated source files that the CDK creates.  Most of us use eclipse, but has some similar items.  There are also some non-support file types and extensions ( addressed in 4.0 ).  However the issue you stated above is new to me.

           

          -Jay

           

          PS: I'm going to move this to the user forum

          • 2. richfaces 3.3.3.final source code compile using Netbeans 6.9.1
            Nina Check Newbie

            I downloaded from the distribution (3.3.3.final).  I opened the project from the pom in NetBeans.  I looked at the dependency jars and it looks like its referencing jsf2.0 libraries and that would be a bit of a problem for compilation wouldn't it?  If I'm using jdk1.5 in the build? 

             

            Is there any build/configuration document available that outlines what versions of java and/or other libraries the build is compatible with?

             

            Thanks