4 Replies Latest reply on Feb 24, 2011 8:39 AM by Ilya Shaikovsky

    Richfaces 4.0 M6 don't work

    barmic Newbie

      Hello,

       

      I want use richfaces 4.0 to build an JSF 2.0 application. I use maven to manage the project. I have read this page : http://community.jboss.org/wiki/HowtoaddRichFaces4xtomavenbasedproject

      and I have now 4 library richfaces in my war file :

      • richfaces-components-ui
      • richefaces-core-impl
      • richfaces-components-api
      • richfaces-core-api

       

      I have remove this of my web.xml :

      <filter>

              <display-name>RichFaces Filter</display-name>

              <filter-name>richfaces</filter-name>

              <filter-class>org.ajax4jsf.Filter</filter-class>

      </filter>

      <filter-mapping>

              <filter-name>richfaces</filter-name>

              <servlet-name>Faces Servlet</servlet-name>

              <dispatcher>REQUEST</dispatcher>

              <dispatcher>FORWARD</dispatcher>

              <dispatcher>INCLUDE</dispatcher>

      </filter-mapping>

       

      The war is now build and deploy without problems but when I try to go in a page of my project I get a page with the componnent as <h:panelGroup> . The JSF component isn't evaluate. I don't know how solve my problem. I try to readd just <filter-mapping> in my web.xml but I have an error during the packaging ("don't know the filter-name richfaces" and "don't know the filter-name null" if I remove <filter-name>). I have try to get the showcase (here : http://www.jboss.org/richfaces/download/nightly) to view the web.xml of this war. But the web.xml is empty.

       

      I don't know how solve my problem and my search on google isn't a good help. I attach my web.xml and faces-config.xml.

       

      Thanks in advance to your help.