5 Replies Latest reply on Feb 28, 2011 5:53 AM by Max Rydahl Andersen

    Eclipse Helios - Content Assist seamtags

    Gary L Newbie

      I've done a fresh download and extraction of the latest Helios Eclipse and then installed the latest Jboss tools through Install Software -> http://download.jboss.org/jbosstools/updates/helios/

       

      What I noticed was that the content assist (ctrl space) does not work for most tags - (a4j, seam, core and many others) on xhtml files, the only one it works for is the ui tags.I installed JBossAS Tools, Seam Tools, JBoss Tools Rich Faces.

       

      I replicated the exact same steps on ganymede and it works out of the box! Are there additional steps required in the helios version or is there a bug?

       

      Thanks for your time in reading this.

        • 1. Eclipse Helios - Content Assist seamtags
          Alexey Kazakov Master

          Is there anything in Eclipse log?

          • 2. Eclipse Helios - Content Assist seamtags
            Gary L Newbie

            I've looked at the eclipse log and it looks fine.

             

            What is strange is that I realised it is not so much eclipse verison dependent as it is workspace dependent.

             

            Eclipse 3.6 -->pointing to working workspace

            Eclipse 3.5 -->pointing to non working workspace

             

            As soon as I switched workspaces 3.5 started encountering the error and 3.6 started to work.

             

            So naturally I proceeded to copy the working project over to the non working  workspace, but it still did not work!

             

            So I tried creating a new workspace on both platforms and neither of them works.

             

            Now I'm guessing it must be some type of config for the plugins in the specific workspace? But I find it strange since both of them are fresh installs.

            • 3. Eclipse Helios - Content Assist seamtags
              Alexey Kazakov Master

              If you create a new workspace for 3.6 and create a new Seam project there, does it work?

              If you create a new worspace and import your old project there, does it work?

              • 4. Eclipse Helios - Content Assist seamtags
                Gary L Newbie

                Ok I've narrowed it down to one file - this is what I did:

                 

                 

                1. I created a fresh java project on Helios

                Then I created a test xhtml file

                Result: Content Assist Does not work

                 

                2. I restarted Helios and opened it again

                Result: Content Assist Does not work

                 

                3. I opened Galileo and open that same workspace and file

                Result: Content Assit Works!

                 

                4. So I then proceeded to open this same file and workspace back in Helios

                Result: Content Assit Works also!

                 

                I took snapshots of the files in step 2 and 3 and did a diff.There was a difference between .\.metadata\.plugins\org.eclipse.core.resources\.projects\***\.indexes\properties.index

                 

                So what I did was repeated step 1 and 2 with a different project name - and then i proceeded to copy the properties.index file over to this new project location and guess what?

                Result: Content Assist Works!

                 

                So the workaround at the moment seems to be opening up the project in galileo and then reopening it up in helios.

                • 5. Eclipse Helios - Content Assist seamtags
                  Max Rydahl Andersen Master

                  This sounds really weird....

                   

                  btw. which editors did you use ? and was it really just a plain java file ?

                   

                  my guess could be that your opening in Galileo triggered another default editor which gets persisted into the resource properties thus when you come back to Helios its not that content assists starts to work but that you are now actually using the right editor.

                   

                  just a hunch.

                   

                  btw. you can see what editor you use in right click on the file and what Open With.. says as the default.