0 Replies Latest reply on Feb 28, 2011 11:26 AM by Aurélien Lansmanne

    Unable to compile JbossW (native) 3.4.0 in Jboss 5.1.0 : help required

    Aurélien Lansmanne Newbie

      Hello,

       

      I was using Jboss 4.2.2 at work when I encountered the following bug : https://issues.jboss.org/browse/JBWS-2845

      Apparently, this issue has been fixed in jbossws-native-3.3.0.Beta4

       

      If I look at the Jboss/JbossWS compatibility wiki page (http://community.jboss.org/wiki/JBossWS-SupportedTargetContainers), I see that I must use at least Jboss 5. So I've switched to Jboss 5.1.0.GA, but the error was still present. I've tried to compile myself Jbossws-native-3.4.0, using the ant task (ant deploy-jboss510).

      Even if the ouput was "SUCCESSFUL", whenever I restart Jboss, the following error appears :

       

      Unexpected error during load of:org.jboss.wsf.spi.invocation.integration.ServiceEndpointContainer
      java.lang.UnsupportedClassVersionError: Bad version number in .class file
                at java.lang.ClassLoader.defineClass1(Native Method)
                at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
                ....
      
      

       

      The same kind of error appears when I run the ant test task, so something must be wrong with my Java configuration. I've checked in MyEclipse, the JRE and JDK are set to Java 1.5.0_16. The compilation has been made using MyEclipse too, and the project was set to the same JDK...

       

      Any suggestion is welcome. If there is a way to download the Jboss-WS binaries without compilation and put them inside Jboss 5.1.0, it may solve my problem. If someone knows a workaround (either ith Jboss 4.2.2 or Jboss 5.0), it could help too.

       

      All I need is to prevent Jboss from generating a tmp WSDL file with a "#" inside... (see the bug at the top of this topic)...

      I can't change the namespace as I'm actually deploying a webservice based on a WSDL which I'm not the author...

       

      Thank you for your help,

       

      Aurélien Lansmanne.