2 Replies Latest reply on Mar 2, 2011 9:23 AM by siben_nayak

    Migrating from JBoss 4 to JBoss 6

    siben_nayak Newbie

      Hello,

       

      I am facing the following error while deploying my application on JBoss 6.0.0Final. The application was working fine on JBoss 4.2.0GA

       

      13:43:14,785 WARN  [ClassLoaderManager] Unexpected error during load of:javax.activation.DataHandler$ObjectDataSource: java.lang.SecurityException: class "javax.activati
      on.DataHandler$ObjectDataSource"'s signer information does not match signer information of other classes in the same package
              at java.lang.ClassLoader.checkCerts(ClassLoader.java:775) [:1.6.0_04]
              at java.lang.ClassLoader.preDefineClass(ClassLoader.java:487) [:1.6.0_04]
              at java.lang.ClassLoader.defineClass(ClassLoader.java:614) [:1.6.0_04]
              at org.jboss.classloader.spi.base.BaseClassLoader.access$200(BaseClassLoader.java:52) [jboss-classloader.jar:2.2.0.GA]
              at org.jboss.classloader.spi.base.BaseClassLoader$2.run(BaseClassLoader.java:650) [jboss-classloader.jar:2.2.0.GA]
              at org.jboss.classloader.spi.base.BaseClassLoader$2.run(BaseClassLoader.java:609) [jboss-classloader.jar:2.2.0.GA]
              at java.security.AccessController.doPrivileged(Native Method) [:1.6.0_04]
              at org.jboss.classloader.spi.base.BaseClassLoader.loadClassLocally(BaseClassLoader.java:608) [jboss-classloader.jar:2.2.0.GA]
              at org.jboss.classloader.spi.base.BaseClassLoader.loadClassLocally(BaseClassLoader.java:585) [jboss-classloader.jar:2.2.0.GA]
              at org.jboss.classloader.spi.base.BaseDelegateLoader.loadClass(BaseDelegateLoader.java:156) [jboss-classloader.jar:2.2.0.GA]
      
      


      Is there a solution to the above problem?

       

      Thanks,

      Siben