1 Reply Latest reply on Mar 7, 2011 7:05 AM by Karel Piwko

    Kept on getting 404s with large EAR

    Victor Tatai Newbie

      Hello,

       

      I know this has been answered before both on the forum and in the FAQ, but I simply cannot get it to work. I have a large EAR which has approximately 80 JARs in it and whenever I try to run a very simple test I get:

       

      {quote}Caused by: java.lang.IllegalStateException: Error launching test at http://localhost:8080/test/ArquillianServletRunner?outputMode=serializedObject&className=com.vocado.services.version.VersionManagerTest&methodName=testGetVersion. Kept on getting 404s.{quote}

       

      I've tried several different options to assemble the EAR, such as:

       

      {code}

      EnterpriseArchive ear = ShrinkWrap.createFromZipFile(EnterpriseArchive.class, new File("/tmp/test.ear"));

      {code}

       

      or

       

      {code}EnterpriseArchive ear = ShrinkWrap.create(EnterpriseArchive.class, "test.ear");

      ear.as(ExplodedImporter.class).importDirectory(new File("/tmp/ear"));{code}

       

      but all of them gave me the exact same result. I even tried creating (as a previous forum post suggested) a fake WAR and adding it to the EAR, but to no avail. Also, as a side note, I have some extra config files in the JBoss server/default/deploy directory - when I deploy the EAR by hand it works ok though.

       

      I am running with Arquillian 1.0.0.Alpha4, Java 1.6.0_22, Maven 3.0.2, JBoss 6.0.0.Final remote.

       

      Thanks,

       

      Victor