6 Replies Latest reply on Apr 5, 2011 5:05 AM by Baptiste MATHUS Branched to a new discussion.

    mod_cluster 1.1.x on JBoss EAP 5.1.0/JBoss AS 5.x

    joaocunhalopes Newbie

      Hello.

       

      I was looking at this ticket:

       

      https://issues.jboss.org/browse/JBPAPP-5048

       

      Its says that

       

      "Note that the status has not been modified and the node will stay there until it is removed by the "new" logic than takes ~ 5 minutes. But the internal

      behaviour is not like the 1.1.x."

       

      I have been using version 1.0.8 GA and I can confirm that this is fixed, i.e., it does take about ~5 minutes for the node to be removed from the mode_cluster_manager web page.

       

      The above setence states that this behaviour is different from 1.1.x. How different? Is the node removal update done in a much faster way?

       

      I would like to try out 1.1.x but I'm using EAP 5.1.0. I have tryed to deploy it and run into some problems.

      I have searched the forums and it seems that others are having the same/similar problems:

       

      http://community.jboss.org/thread/34965

       

      Is there a clear/consise guide on how to deploy mod_cluster 1.1.x on EAP 5.1.0?

      It should be the same for JBoss AS 5.x.

      Thank you.

        • 1. mod_cluster 1.1.x on JBoss EAP 5.1.0/JBoss AS 5.x
          Paul Ferraro Master

          To deploy mod_cluster 1.1.x in EAP 5.1.0, just copy the mod_cluster.sar to your $JBOSS_HOME/server/production/deploy directory - that's it.

          If you want to use mod_cluster in a profile that does not include JBoss clustering (specifically, one that deploys the HAPartition bean), then edit the mod_cluster.sar/META-INF/mod_cluster-jboss-beans.xml file, and modify the ModClusterListener bean, and replace "HAModClusterService" with "ModClusterService".

           

          What kinds of problems are you having?

          • 2. mod_cluster 1.1.x on JBoss EAP 5.1.0/JBoss AS 5.x
            joaocunhalopes Newbie

            We are using a JBoss EAP 5.1.0 profile, based on the out of the box "production" profile. It as been slimmed so quite a few services were removed.

            That said, mod_cluster 1.0.8 GA runs withouterrors, and yes, we are using the HAModClusterService.

            As for 1.1.1 Final, after deployment, the exception that I have is:

             

            2011-03-04 22:33:17,732 ERROR [org.jboss.kernel.plugins.dependency.AbstractKernelController] (main) Error installing to Start: name=WebServer state=Create

            java.lang.ClassCastException: org.jboss.modcluster.ha.HAModClusterService cannot be cast to org.apache.catalina.LifecycleListener

             

            I'm sure that this a configuration problem so I'll check everything and post here if I can't solve it.

            Thank you.

            • 3. mod_cluster 1.1.x on JBoss EAP 5.1.0/JBoss AS 5.x
              Paul Ferraro Master

              It looks like your production profile still contains modifications to the jbossweb service for use with mod_cluster 1.0.x.  mod_cluster 1.1.x is meant to work with the default jbossweb server.xml and jboss-beans.xml files.  So, revert any changes you made within jbossweb.sar when you initially setup mod_cluster 1.0.x.  Then, everything should work.

              • 4. mod_cluster 1.1.x on JBoss EAP 5.1.0/JBoss AS 5.x
                joaocunhalopes Newbie

                That's correct!

                Replaced

                 

                server\<profile>\deploy\jbossweb.sar\server.xml

                and

                server\<profile>\deploy\jbossweb.sar\META-INF\jboss-beans.xml

                 

                with the original, unmodded files, and it works.

                 

                Also checked the manual, and it does say:

                 

                >2.5. Configuring the server-side

                >2.5.1. Configuring mod_cluster with JBoss AS 5.x+

                >No post-installation configuration necessary!

                 

                This is quite different from 1.0.x (and just great)!

                 

                A final question: for a production envirnoment would you recommned 1.0,8 GA or 1.1.1 Final?

                 

                Not sure if the question is logical, I don't know the product road map, and I'm assuming 1.0.x and 1.1.x are different branches.

                Thank you.

                • 5. mod_cluster 1.1.x on JBoss EAP 5.1.0/JBoss AS 5.x
                  Paul Ferraro Master

                  Great.  One of the goals of 1.1.x was to improve the server-side integration.

                  I'd using recommend 1.1.x, unless you need RH support - in which case, you'll need to stick with 1.0.x for now.

                  • 6. mod_cluster 1.1.x on JBoss EAP 5.1.0/JBoss AS 5.x
                    Baptiste MATHUS Newbie
                    I'd using recommend 1.1.x, unless you need RH support - in which case, you'll need to stick with 1.0.x for now.

                    Sorry for stepping in, but as it's the very same subject I thought I could ask the question here to keep the information in one place.

                     

                    I'm also using EAP 5.1 and was wondering about the mod_cluster 1.1.x integration into JBoss EAP (as a supported.

                    Any roadmap about it (or even a JBPAPP-xyz patch?)?

                     

                    Thanks a lot for your answer.