0 Replies Latest reply on Mar 7, 2011 11:20 AM by Anton Gavazuk

    java.lang.ClassCastException: com.sun.xml.messaging.saaj.soap.ver1_1.Envelope1_1Impl cannot be cast to org.jboss.ws.core.soap.SOAPElementImpl

    Anton Gavazuk Newbie

      Hi all,

       

       

      JDK 1.6

      my env - JBoss EAP 5.0,

      JBoss Web Services - Stack Native Core, v 3.1.2.SP3

       

      I tried to introduce new WS proxy to my application (EAR), generated required artifacts with wsconsume, tested them in standalone mode (no problems) and packaged in the application - and during the call an ws proxy I get error:

       

      Caused by: java.lang.ClassCastException: com.sun.xml.messaging.saaj.soap.ver1_1.Envelope1_1Impl cannot be cast to org.jboss.ws.core.soap.SOAPElementIm

      pl

              at org.jboss.ws.core.soap.SOAPEnvelopeImpl.<init>(SOAPEnvelopeImpl.java:57)

              at org.jboss.ws.core.soap.EnvelopeBuilderDOM.build(EnvelopeBuilderDOM.java:136)

              at org.jboss.ws.core.soap.EnvelopeBuilderDOM.build(EnvelopeBuilderDOM.java:96)

              at org.jboss.ws.core.soap.MessageFactoryImpl.createMessage(MessageFactoryImpl.java:294)

              at org.jboss.ws.core.soap.SOAPMessageUnMarshallerHTTP.read(SOAPMessageUnMarshallerHTTP.java:82)

              at org.jboss.remoting.transport.http.HTTPClientInvoker.readResponse(HTTPClientInvoker.java:584)

              at org.jboss.remoting.transport.http.HTTPClientInvoker.useHttpURLConnection(HTTPClientInvoker.java:381)

              at org.jboss.remoting.transport.http.HTTPClientInvoker.makeInvocation(HTTPClientInvoker.java:232)

              ... 90 more

       

      My EAR doesnt contain any packaged jars, the content of my lib/endorsed is that:

      activation.jar jaxb-api.jar jbossws-native-jaxws.jar jbossws-native-jaxws-ext.jar jbossws-native-saaj.jar resolver.jar serializer.jar stax-api.jar xalan.jar xercesImpl.jar

       

      For the moment I'm stuck, tried to search and play in different ways, have no idea how to resolve it apart from migrating to another ws lib (Axis...)

       

      Thanks!