3 Replies Latest reply on Mar 10, 2011 3:39 AM by Wim Vandenhaute

    JBoss AS 6.0.0.Final EJB3 deployment error

    Wim Vandenhaute Newbie

      Hey all,

       

      I am in the process of updating a project previously running on jboss 4.2.3 to jboss 6.0.0.Final.

      Yet I am getting a depoyment error which I am having trouble to resolve.

       

      http://pastebin.com/YzFBcecw

       

      As the jboss log says, the SLSB gets installed ok, yet when registering something goess iffy.

       

      Any ideas?

       

      Kind regards,

      Wim.

        • 1. JBoss AS 6.0.0.Final EJB3 deployment error
          Wim Vandenhaute Newbie

          Also I am still using EJB3.0. Have 1 SLSB defined in the ejb-jar  as shown below.

           

          <ejb-jar xmlns="http://java.sun.com/xml/ns/javaee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

                   xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/ejb-jar_3_0.xsd" version="3.0">

           

           

              <enterprise-beans>

           

                  <session>

                      <ejb-name>InitTaskSchedulingTaskBean</ejb-name>

                      <ejb-class>net.link.safeonline.model.task.init.InitTaskSchedulingTaskBean</ejb-class>

                      <env-entry>

                          <env-entry-name>defaultCronExpression</env-entry-name>

                          <env-entry-type>java.lang.String</env-entry-type>

                          <env-entry-value>

                              ${defaultCronExpression}

                          </env-entry-value>

                      </env-entry>

                  </session>

           

              </enterprise-beans>

          </ejb-jar>

          • 2. JBoss AS 6.0.0.Final EJB3 deployment error
            Wim Vandenhaute Newbie

            I figured it out myself.

             

            There were some dependency issues due to the fact I customized the jboss distribution for using jaxws-ri 2.1.4.

             

            This caused org.jboss.switchboard.WebServiceRefResourceProvider and org.jboss.switchboard.WebServiceContextResourceProvider gone missing causing the switchboard jndi resource provider also gone missing obviously causing my blowup.

             

            Kind regards,

            Wim.

            • 3. JBoss AS 6.0.0.Final EJB3 deployment error
              Wim Vandenhaute Newbie

              Some more info case somebody is interested.

               

              I threw out

               

              server/default/deployers/jbossws.deployer/**

              server/default/deployers/jbossws-jaxrpc.deployer/**

              server/default/deployers/resteasy.deployer/jaxb-impl-2.2.jar

              lib/endorsed/jbossws-native-factories.jar

              lib/endorsed/jboss-jaxb-api_2.2_spec.jar

              lib/endorsed/jboss-jaxws-api_2.2_spec.jar

              lib/endorsed/jbossws-cxf-factories.jar

              common/deploy/jbossws-console.war/**

               

              So I could put my own jaxws runtime in it.

              But that meant server/default/deployers/jbossws.deployer/META-INF/stack-agnostic-jboss-beans.xml was also removed, which defines the 2 WebService resource providers.

               

              So my fix was to patch this deployer for my sake and only leave those 2 bean definitions, which seems to work ok.