2 Replies Latest reply on Apr 8, 2011 5:37 AM by Mano Swerts

    autocomplete turned off when using ajaxValidator

    Mano Swerts Newbie

      Hi all,

       

      I have a problem regarding issue https://issues.jboss.org/browse/RF-8430. This issue should be fixed, but I'm still experiencing the same problem.

       

      I am using RichFaces 3.3.3.Final as you can see in the following code snippet from my pom.xml:

       

       

      {code:xml}

      ...

      <dependency>

          <groupId>org.richfaces.framework</groupId>

          <artifactId>richfaces-api</artifactId>

          <version>3.3.3.Final</version>

      </dependency>

      <dependency>

          <groupId>org.richfaces.framework</groupId>

          <artifactId>richfaces-impl</artifactId>

          <version>3.3.3.Final</version>

      </dependency>

      <dependency>

          <groupId>org.richfaces.ui</groupId>

          <artifactId>richfaces-ui</artifactId>

          <version>3.3.3.Final</version>

      </dependency>

      ...

      {code}

       

      This is the XHTML code snippet for my input field (input.xhtml = facelet):

       

       

      {code:xml}

      ...

      <h:inputText id="txt_#{id}" value="#{value}" disabled="#{disabled}" rendered="#{visible}"

                                                               required="#{isMandatory}" size="#{inputSize}" >

                 <rich:ajaxValidator event="onblur"/>

      </h:inputText>

      ...

      {code}

       

      The moment that validation occurs, the input field gets the autocomplete="off" attribute. Am I doing something wrong?

       

      Kind regards,

       

      Mano