1 Reply Latest reply on Apr 4, 2011 5:12 AM by Aslak Knutsen

    jbossas embedded 6 using shrinkwrap 1.0.0-alpha-11?

    Steve Maring Newbie

      While writing some unit tests, I've noticed that there have been some method name changes in Shrinkwrap between 1.0.0-alpha-11 and 1.0.0-alpha-12.  I seem to be running into some interesting problems with maven in that the jboss-as-depchain 6.0.0.Final and arquillian-jbossas-embedded-6 poms have declared 1.0.0-alpha-11 as their dependencies.

      +- org.jboss.arquillian:arquillian-junit:jar:1.0.0.Alpha5:test

      |  \- org.jboss.arquillian:arquillian-impl-base:jar:1.0.0.Alpha5:test

      |     +- org.jboss.arquillian:arquillian-api:jar:1.0.0.Alpha5:test

      |     |  \- org.jboss.shrinkwrap.descriptors:shrinkwrap-descriptors-api:jar:0.1.4:test

      |     +- org.jboss.shrinkwrap.resolver:shrinkwrap-resolver-api:jar:1.0.0-alpha-12:test

      |     +- org.jboss.shrinkwrap.resolver:shrinkwrap-resolver-api-maven:jar:1.0.0-alpha-12:test

      |     \- org.jboss.shrinkwrap.resolver:shrinkwrap-resolver-impl-maven:jar:1.0.0-alpha-12:test

       

       

      +- org.jboss.arquillian.container:arquillian-jbossas-embedded-6:jar:1.0.0.Alpha5:test

      |  +- org.jboss.arquillian:arquillian-spi:jar:1.0.0.Alpha5:test

      |  +- org.jboss.shrinkwrap:shrinkwrap-impl-base:jar:1.0.0-alpha-11:test

       

       

      +- org.jboss.jbossas:jboss-as-depchain:pom:6.0.0.Final:test

      |  +- org.jboss.shrinkwrap:shrinkwrap-api:jar:1.0.0-alpha-11:test

      |  +- org.jboss.shrinkwrap:shrinkwrap-spi:jar:1.0.0-alpha-11:test

      |  +- org.jboss.shrinkwrap:shrinkwrap-extension-vdf:jar:1.0.0-alpha-11:test

      |  +- org.jboss.shrinkwrap:shrinkwrap-extension-vfs3:jar:1.0.0-alpha-11:test

       

       

      Things seem to work OK if I explicitly define the version of Shrinkwrap I want ....

       

              <dependency>

                  <groupId>org.jboss.shrinkwrap</groupId>

                  <artifactId>shrinkwrap-impl-base</artifactId>

                  <version>1.0.0-alpha-12</version>

                  <scope>test</scope>

              </dependency>

       

              <dependency>

                  <groupId>org.jboss.shrinkwrap</groupId>

                  <artifactId>shrinkwrap-api</artifactId>

                  <version>1.0.0-alpha-12</version>

                  <scope>test</scope>

              </dependency>       

       

              <dependency>

                  <groupId>org.jboss.shrinkwrap</groupId>

                  <artifactId>shrinkwrap-spi</artifactId>

                  <version>1.0.0-alpha-12</version>

                  <scope>test</scope>

              </dependency>