3 Replies Latest reply on Apr 4, 2011 4:06 PM by Clebert Suconic

    hornetq 2.1.2 in jboss4.0.4 Error: Logger.isTraceEnabled()

    Steven Landers Newbie

      It appears that JBoss 4.0.4 is using an old version of log4j that hornetq doesn't like.  Does anyone have any ideas regarding how this could be resolved?  I currently cannot start JBoss4 immediately after installing hornetq.

       

      ObjectName: jboss.jca:service=RARDeployment,name='jms-ra.rar'

        State: FAILED

        Reason: java.lang.NoSuchMethodError: org.apache.log4j.Logger.isTraceEnabled()Z

        Depends On Me:

          jboss.jca:service=ManagedConnectionFactory,name=JmsXA

       

       

      ObjectName: org.hornetq:service=HornetQJMSStarterService

        State: FAILED

        Reason: java.lang.NoSuchMethodError: org.apache.log4j.Logger.isTraceEnabled()Z

        I Depend On:

          org.hornetq:service=HornetQStarterService

       

       

      Things I've tried:

      - updating jboss's log4j

      - including a newer version of log4j in clever places

       

      I would absolutely love to upgrade our application server from the ancient 4.0.4, but currently, our application (voip call handling) doesn't deploy on a later version due to other classloader issues (and it's not my decision.  Yes, I think those issues are worth fixing).  I think a reasonable alternative would be to deploy hornetq in a standalone mode on the same server.  The directive is currently to 'get hornetq in jboss4' - which is the task I'm wrestling with currently.

       

      Any thoughts?