3 Replies Latest reply on Apr 6, 2011 5:33 PM by Juan Camilo Prada

    RichFaces app does not work in IE6 over HTTPS

    Val Blant Newbie

      I'm totally stumped here, so any ideas would be appreciated. This is probably not a RichFaces problem, but I ask the question here in hopes that someone ran into this before.

      I have a RichFaces application, which recently became non-functional when used from IE6. The problem began when I included the following line in my main template:

      <a4j:loadScript src="resource://jquery.js"/>

      This results in the following generated HTML:

      <script src="/AgriShare/a4j/g/3_3_3.Finaljquery.js.jsf" type="text/javascript"></script>

      By "non-functional" I mean that pages no longer load, b/c the first page appears to hang the browser for a long time, and then all further references to jQuery say that the object was not defined. Eventually this appears to put IE6 in a state where further clicks do nothing.

      After a lot of trial and error I have established the following:

      • The app still works in Chrome, Firefox and IE8
      • The app still works in IE6, if I switch to HTTP. So, the problem appears to be related to HTTPS, which I can't dispose of.
      • I further narrowed down the problem by trying to manually request 3_3_3.Finaljquery.js.jsf in IE6 address bar. It asks me if I want to save the file (so it can see it is there), but when I say 'Save', it hangs for about 5 seconds and then says:
      Internet Explorer cannot download 3_3_3.Finaljquery.js.jsf from [host_name]. The connection with the server was reset.
      • Doing the same download over HTTP succeeds.
      • Gradually reducing the size of the file, I noticed that the download eventually succeeds over HTTPS, if I get the files size below ~ 110KB. There is no specific size it works at though. I tried the same trick with prototype.js and it worked at a different size value.

       

      So, it looks like the app is not working b/c jquery.js file is somehow too big. I can't trace the SSL session, b/c I cannot get access to the certificate's private key, so now I have absolutely no clue what to try next.

       

      Any ideas would be greatly appreciated.