1 Reply Latest reply on Apr 16, 2011 4:24 PM by Joseph Hwang

    Exception in thread "main" javax.xml.ws.WebServiceException: No Content-type in the header

    Joseph Hwang Novice

      I made JBossWS code and deloyed it. Deployment was successful.

      In JbossWS environment, I generated SampleClient.java.

       

      package com.aaa.ws.clientsample;

      import com.aaa.ws.*;

       

       

      public class ClientSample {

       

       

      public static void main(String[] args) {

         System.out.println("***********************");
         System.out.println("Create Web Service Client...");
         WSHelloWorldService service1 = new WSHelloWorldService();
         System.out.println("Create Web Service...");
         WSHelloWorld port1 = service1.getWSHelloWorldPort();
         System.out.println("Call Web Service Operation..."); // No Exception occurs until this line
         System.out.println("Server said: " + port1.sayHello("aaa")); // Exception Occurs  

         System.out.println("***********************");
         System.out.println("Call Over!");
         }
      }

       

       

       

      Exception is

       

      ***********************

      Create Web Service Client...

      Create Web Service...

      Call Web Service Operation...

      Exception in thread "main" javax.xml.ws.WebServiceException : No Content-type in the header!

      ....

       

      I copyed the following libraries found in JBOSS_HOME/common/lib to the endorsed folder (JBOSS_HOME/lib/endorsed).

       

      jbossws-native-jaxrpc.jar

      jbossws-native-jaxws.jar

      jbossws-native-jaxws-ext.jar

      jbossws-native-saaj.jar

       

      But this time Web Service Deployment causes exception.!

       

      Did I miss any process? Pls give me some advice.!!

       

      Best Regard!