2 Replies Latest reply on Apr 12, 2011 2:20 PM by Alejandro Montenegro

    problems resolving com.dyuproject dependencies

    Alejandro Montenegro Novice

      Hi Guys,

      at my branch I just executed:

       

      >git fetch upstream

      >git merge upstream/master

       

      After that I tried to rebuild the branch by executing:

       

      >mvn clean install

       

      But I get the following error:

       

      [INFO] Scanning for projects...

      [INFO] snapshot org.switchyard:switchyard-parent:0.1.0-SNAPSHOT: checking for updates from maven2-repository.java.net

      [INFO] snapshot org.switchyard:switchyard-parent:0.1.0-SNAPSHOT: checking for updates from codehaus.m2.snapshots

      [INFO] ------------------------------------------------------------------------

      [ERROR] FATAL ERROR

      [INFO] ------------------------------------------------------------------------

      [INFO] Error building POM (may not be this project's POM).

       

       

      Project ID: org.switchyard:switchyard-runtime

      POM Location: J:\dev\src\switchyard\switchyard-core\runtime\pom.xml

      Validation Messages:

       

          [0]  'dependencies.dependency.version' is missing for com.dyuproject.protostuff:protostuff-api:jar

          [1]  'dependencies.dependency.version' is missing for com.dyuproject.protostuff:protostuff-core:jar

          [2]  'dependencies.dependency.version' is missing for com.dyuproject.protostuff:protostuff-collectionschema:jar

          [3]  'dependencies.dependency.version' is missing for com.dyuproject.protostuff:protostuff-runtime:jar

          [4]  'dependencies.dependency.version' is missing for com.dyuproject.protostuff:protostuff-json:jar

          [5]  'dependencies.dependency.version' is missing for com.dyuproject.protostuff:protostuff-xml:jar

       

       

      Reason: Failed to validate POM for project org.switchyard:switchyard-runtime at J:\dev\src\switchyard\switchyard-core\runtime\pom.xml

       

      It looks like it's not able to resolve de version of the dyuproject dependency, so the question is if I am the only one who is having this problem? or are others also facing this?

      If Im the only one, maybe my merge screwed.. :S

       

      thanks

      Alejandro