7 Replies Latest reply on Jul 21, 2009 8:57 AM by Gérard Baste

    display problems

    Gérard Baste Newbie

      Hi everyone,

      I am facing problems with the RichFaces deployment in my application.

      I am using Eclipse Ganymede, Tomcat 6.0, JSF 1.2 and JDK 5.0. I downloaded RichFaces 3.2, changed my web.xml, and put a Calendar in a JSP page, just to try the result.

      I get no error in the server or in Eclipse, but still the calendar does not display, and does not work. The problem is the same for a Gmap, and so on...

      Here is the way the Calendar is displayed:
      http://img140.imageshack.us/img140/6285/jars.jpg

      I do not know what to do, as I tried everything possible.

      Could someone please help me?

      Thank you!

        • 1. Re: display problems
          Ilya Shaikovsky Master

          check for firebug Net tab. Which states has resources requests?

          and need more concrete code and config info.

          • 2. Re: display problems
            Gérard Baste Newbie

            Thank you for the quick answer, here is a picture of my WEB-INF/lib folder contents:
            http://img27.imageshack.us/img27/1258/jarsstrue.th.jpg

            And here is my web.xml:

            <?xml version="1.0" encoding="UTF-8"?>
            <web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
             xmlns="http://java.sun.com/xml/ns/javaee" xmlns:web="http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd"
             xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd"
             id="WebApp_ID" version="2.5">
            
             <display-name>DataEntry</display-name>
            
             <welcome-file-list>
             <welcome-file>/index.jsp</welcome-file>
             </welcome-file-list>
            
             <context-param>
             <param-name>org.richfaces.SKIN</param-name>
             <param-value>blueSky</param-value>
             </context-param>
             <!--
             <context-param>
             <param-name>org.richfaces.LoadStyleStrategy</param-name>
             <param-value>ALL</param-value>
             </context-param>
             <context-param>
             <param-name>org.richfaces.LoadScriptStrategy</param-name>
             <param-value>ALL</param-value>
             </context-param>
             -->
            
             <filter>
             <display-name>RichFaces Filter</display-name>
             <filter-name>richfaces</filter-name>
             <filter-class>org.ajax4jsf.Filter</filter-class>
             </filter>
             <filter-mapping>
             <filter-name>richfaces</filter-name>
             <servlet-name>Faces Servlet</servlet-name>
             <dispatcher>REQUEST</dispatcher>
             <dispatcher>FORWARD</dispatcher>
             <dispatcher>INCLUDE</dispatcher>
             </filter-mapping>
             <!--
             <filter>
             <filter-name>MyFacesExtensionsFilter</filter-name>
             <filter-class>org.apache.myfaces.webapp.filter.ExtensionsFilter</filter-class>
             </filter>
             <filter-mapping>
             <filter-name>MyFacesExtensionsFilter</filter-name>
             <url-pattern>/faces/myFacesExtensionRessource/*</url-pattern>
             </filter-mapping>
             -->
            
             <servlet>
             <servlet-name>Faces Servlet</servlet-name>
             <servlet-class>javax.faces.webapp.FacesServlet</servlet-class>
             <load-on-startup>1</load-on-startup>
             </servlet>
            
             <servlet-mapping>
             <servlet-name>Faces Servlet</servlet-name>
             <url-pattern>*.jsf</url-pattern>
             <url-pattern>/faces/*</url-pattern>
             </servlet-mapping>
             <error-page>
             <error-code>500</error-code>
             <location>/VueErreur.jsp</location>
             </error-page>
            
            </web-app>
            



            I do not know what is Firebug, but when I run my application in FireFox, I get the following errors in the error console:
            "RichFaces is not defined"
            "Calendar" is not defined
            "ProgressBar" is not defined


            Thank you for helping me.

            • 3. Re: display problems
              Gérard Baste Newbie

              Sorry, here is the right picture of my jars into the lib folder:
              http://img27.imageshack.us/img27/1258/jarsstrue.jpg

              • 4. Re: display problems
                Ilya Shaikovsky Master

                okay.. and show the page please also. if included show both parent and include.

                • 5. Re: display problems
                  Gérard Baste Newbie

                  Ok, so here is my welcome page (index.jsp):

                  <jsp:forward page="/VueConnexion.jsf"></jsp:forward>
                  


                  and the "VueConnexion.jsp":
                  <?xml version="1.0" encoding="ISO-8859-1" ?>
                  <%@ page language="java" contentType="text/html; charset=ISO-8859-1"
                   pageEncoding="ISO-8859-1"%>
                  <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
                  
                  <%-- JSF taglibs --%>
                  <%@taglib uri="http://java.sun.com/jsf/html" prefix="h" %>
                  <%@taglib uri="http://java.sun.com/jsf/core" prefix="f" %>
                  <%@taglib uri="http://richfaces.org/rich" prefix="rich" %>
                  <%@taglib uri="http://richfaces.org/a4j" prefix="a4j" %>
                  
                  <html xmlns="http://www.w3.org/1999/xhtml"
                   xmlns:f="http://java.sun.com/jsf/core"
                   xmlns:h="http://java.sun.com/jsf/html">
                  <head>
                  <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
                  
                  <link rel="stylesheet" type="text/css" href="./default/css/ownStyle.css" />
                  
                  <title>Web Data Admin Home page</title>
                  </head>
                  <body>
                   <f:view>
                  
                   <jsp:include page="./default/html/banner.html" />
                  
                   <div class="global">
                   <h2>
                   Web Data Admin
                   </h2>
                  
                   <div class="inside">
                   <div class="inside2">
                   Please login:
                   <br /><br />
                   </div>
                  
                   <!--
                   <rich:gmap lat="90" lng="70" />
                   -->
                  
                   <h:messages />
                   <h:form>
                  
                  
                  
                   <rich:dropDownMenu>
                   <rich:menuItem value="Active" />
                   </rich:dropDownMenu>
                   <rich:calendar id="todate" value="#{connexion.dateTest}" datePattern="MM/dd/yyyy">
                   </rich:calendar>
                  
                   <rich:fileUpload />
                  
                  
                   <!-- là c'est le vrai truc-->
                   <h:panelGrid columns="2">
                   <h:outputLabel value="Login"></h:outputLabel>
                   <h:inputText value="#{connexion.login}"></h:inputText>
                  
                   <h:outputLabel value="Password"></h:outputLabel>
                   <h:inputSecret value="#{connexion.motDePasse}"></h:inputSecret>
                   </h:panelGrid>
                  
                  
                   <h:commandButton value="Submit" action="#{connexion.valider}"></h:commandButton>
                  
                   </h:form>
                  
                  
                   </div>
                   </div>
                  
                  
                  
                   </f:view>
                  </body>
                  </html>
                  


                  Finally, the "banner.html" file:
                  <ul class="navbar">
                   <li class="home">
                   <a href="index.jsp">Home</a>
                   </li>
                   <li class="about">
                   <a href="about.htm">About</a>
                   </li>
                   <li class="programmes">
                   <a href="default/html/useNotice.html">Notice of use</a>
                   </li>
                   <li class="infres">
                   <a href="info_resources.htm">Information</a>
                   </li>
                   <li class="meetings">
                   <a href="meetings.htm">Trouble shoot</a>
                   </li>
                   <li class="home">
                   <a href="site_map.htm">Help</a>
                   </li>
                   <li class="contact">
                   <a href="contact.htm">Contact us</a>
                   </li>
                  </ul>
                  
                  
                  <br /><br /><br /><br /><br /><br /><br /><br /><br /><br />
                  




                  Thank you for the help.

                  • 6. Re: display problems
                    Ilya Shaikovsky Master

                     

                     <servlet-mapping>
                     <servlet-name>Faces Servlet</servlet-name>
                     <url-pattern>*.jsf</url-pattern>
                     <url-pattern>/faces/*</url-pattern>
                     </servlet-mapping>
                    


                    split this to two mappings. one of the patterns ignored using this definition.

                    • 7. Re: display problems
                      Gérard Baste Newbie

                      Great!!!

                      That did work.
                      Thank you, it has been 2 days I am seeking andd posting messages on forums around.

                      Thank you very much!!!!!!!!!!