3 Replies Latest reply: Apr 13, 2011 2:25 PM by vishals RSS

    Out of memory issue with JBoss EAP 5.1.0

    vishals Newbie

      Hi All,

       

      I am trying to migrate my applications from JBoss 4.2.1.GA to JBoss EAP 5.1.0 and when I start the server I end up getting either out of memory or Permgen space error. I tried tweaking the -Xms and -Xmx parameters, but nothing seems to work. I am running on Windows 7 machine with 4GB ram (available for use 2.8 GB). The JDK version is 1.6_18. Also tried on JDK 1.6_24. 

       

       

      Given below is the console output when I start JBoss.

      C:\jboss-eap-5.1\jboss-as\bin>run
      Calling C:\jboss-eap-5.1\jboss-as\bin\run.conf.bat
      ===============================================================================

        JBoss Bootstrap Environment

        JBOSS_HOME: C:\jboss-eap-5.1\jboss-as

        JAVA: C:\Program Files\Java\jdk1.6.0_18\bin\java

        JAVA_OPTS: -Xms40m -Xmx1303m -XX:+HeapDumpOnOutOfMemoryError -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djava.net.preferIPv4Stack=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Dorg.jboss.resolver.warning=true -Dprogram.name=run.bat -server

      CLASSPATH: C:\Program Files\Java\jdk1.6.0_18\lib\tools.jar;C:\jboss-eap-5.1\jboss-as\bin\run.jar

      ===============================================================================

       

      Also find attached run.bat and run.conf.bat.

       

      Please help.

       

      Thanks,

      Vishal