0 Replies Latest reply on Apr 21, 2011 9:02 AM by impio funicular

    Spring framework version

    impio funicular Newbie

      When I try to deploy a  war  which uses say spring-2.0.6.jar I'm getting this exception:

      java.lang.IllegalArgumentException: Class [org.apache.cxf.transport.http_jetty.spring.NamespaceHandler] does not implement the NamespaceHandler interface


      org.apache.cxf.transport.http_jetty.spring.NamespaceHandler class extends NamespaceHandlerSupport which implements NamespaceHandler interface.

      Neither NamespaceHandlerSupport class or NamespaceHandler interface hasn't changed from version 2.0.6 to 2.5.6.



      So the questions are:

      Is the deployer trying to load the beans defined in my war hence using its own spring jars?

      If I want to use another vesion of spring, is there any way I can configure the deployer not to do so (if that is the case) ?