5 Replies Latest reply on Apr 26, 2011 10:23 AM by stephan972

    JBoss - Custom minimal configuration problem

    stephan972 Newbie

      Hi,

       

      I'm trying to build a very small JBoss configuration. Here are my requirements :

       

      - Hot-Deploy activated

      - JBoss Web Server installed

      - Deployment of the following application types only: war, *-ds.xml

      - The configuration MUST be minimal, no extra beans etc allowed !

      <br><br>

       

      So I came up with the following configuration called `custom` roughtly inspired from the `default` configuration. It looks like this under `<path_to_jboss>\server` :

       

      <pre>

      custom:

      total 0

      d---------+ 1 Stephan 0 Apr 21 17:43 conf

      d---------+ 1 Stephan 0 Apr 21 17:54 deploy

      d---------+ 1 Stephan 0 Apr 21 16:21 deployers

      d---------+ 1 Stephan 0 Apr 20 11:30 log

       

      custom/conf:

      total 5

      d---------+ 1 Stephan    0 Apr 21 17:43 bootstrap

      ----------+ 1 Stephan  285 Apr 21 17:43 bootstrap.xml

      ----------+ 1 Stephan 1339 Apr 21 17:11 jboss-service.xml

       

      custom/conf/bootstrap:

      total 16

      ----------+ 1 Stephan 1089 Apr 20 11:53 classloader.xml

      ----------+ 1 Stephan 6864 Apr 21 17:58 custom.xml

      ----------+ 1 Stephan 1683 Apr 21 17:08 profile.xml

       

      custom/deploy:

      total 4

      ----------+ 1 Stephan 3383 Apr 21 10:50 DummyJSP-0.0.1-SNAPSHOT.war

      d---------+ 1 Stephan    0 Apr 21 11:53 jbossweb.sar

       

      custom/deploy/jbossweb.sar:

      total 4681

      d---------+ 1 Stephan       0 Apr 21 11:53 META-INF

      ----------+ 1 Stephan     625 May 22  2009 context.xml

      ----------+ 1 Stephan 1472523 May 22  2009 jasper-jdt.jar

      ----------+ 1 Stephan  354752 May 22  2009 jboss-web-service.jar

      ----------+ 1 Stephan 2526136 May 22  2009 jbossweb.jar

      d---------+ 1 Stephan       0 Apr 21 11:53 jsf-libs

      ----------+ 1 Stephan  419803 May 22  2009 jstl.jar

      ----------+ 1 Stephan    8465 May 22  2009 server.xml

       

      custom/deploy/jbossweb.sar/META-INF:

      total 9

      ----------+ 1 Stephan 4444 May 22  2009 jboss-beans.xml

      ----------+ 1 Stephan  375 May 22  2009 jboss-structure.xml

       

      custom/deploy/jbossweb.sar/jsf-libs:

      total 1180

      ----------+ 1 Stephan  11692 May 22  2009 jboss-faces.jar

      ----------+ 1 Stephan 358333 May 22  2009 jsf-api.jar

      ----------+ 1 Stephan 835518 May 22  2009 jsf-impl.jar

       

      custom/deployers:

      total 0

      d---------+ 1 Stephan 0 Apr 21 16:21 jbossweb.deployer

       

      custom/deployers/jbossweb.deployer:

      total 64

      d---------+ 1 Stephan     0 Apr 21 16:21 META-INF

      ----------+ 1 Stephan 15070 May 22  2009 jboss-web-deployer.jar

      ----------+ 1 Stephan 48233 Apr 12 18:04 web.xml

       

      custom/deployers/jbossweb.deployer/META-INF:

      total 13

      ----------+ 1 Stephan   322 May 22  2009 jboss-structure.xml

      ----------+ 1 Stephan 11658 May 22  2009 war-deployers-jboss-beans.xml

       

      custom/log:

      total 20

      ----------+ 1 Stephan 19231 Apr 21 17:58 boot.log

      </pre>

       

      The microcontainer loads and run successfully but neither DummyJSP-0.0.1-SNAPSHOT.war is deployed nor jbosswebserver seems to run on 8080.

       

      What am i missing ?

       

      JBoss version : 5.1.0GA