0 Replies Latest reply on Apr 28, 2011 10:25 PM by Roberto Requena

    <rich:messages> not shown.

    Roberto Requena Newbie

      Greetings,

       

      I have the following problem. my base template has a section to display messages, but these shows sometimes, and sometimes not. My backend beam inherit from a base class that contains methods to display the following messages:


          public static void addInfoMessage(String msg) {
              addInfoMessage(null, msg, null);
          }
      
           public static void addInfoMessage(String clientId, String msg, String detalles) {
              FacesContext.getCurrentInstance().addMessage(clientId, new FacesMessage(FacesMessage.SEVERITY_INFO, msg, detalles));
          }
      
          public static void addErrorMessage(String msg) {
              addErrorMessage(null, msg, null);
          }
      
          public static void addErrorMessage(String clientId, String msg, String detalles) {
              FacesContext.getCurrentInstance().addMessage(clientId, new FacesMessage(FacesMessage.SEVERITY_ERROR, msg, detalles));
          }
      

       

      and in my file. xhtm I have the following code:

       

       

      <rich:messages globalOnly="true" layout="table" errorClass="error2" infoClass="info" warnClass="notice" >
      <f:facet name="header">
      <h:outputText value="Entered Data Status:"></h:outputText>
      </f:facet>
      <f:facet name="passedMarker">
      <h:graphicImage value="/imagenes/iconos/accept.png" />
      </f:facet>
      <f:facet name="errorMarker">
      <h:graphicImage value="/imagenes/iconos/cancel.png" />
      </f:facet>
      <f:facet name="infoMarker">
      <h:graphicImage value="/imagenes/iconos/information.png" />
      </f:facet>
      </rich:messages>
      

       

      and my business method of beam backen use the following call:


              //We set the success message
              addInfoMessage("ok update record");
      

       

      in some pages that shows me info messages, and other pages also shows me the error messages. I can give some help to determine what might cause this behavior.

                                      Thanks for your help and excuse my English