0 Replies Latest reply on May 12, 2011 11:11 AM by jwinklba

    Two separate Clusters in one Network using Unicast

    jwinklba Newbie

      Hello,

       

      we want to operate two separat JBoss Clusters (Prod and Dev) with 2 nodes each in the same Network. Both Clusters run on Windows 2008, JDK 1.5.0_19 64-Bit and JBoss 4.2.2 GA. I configured the clusters according to this instruction, with the only difference that we have to use Unicast, Multicast is not an option.

       

      While running both Clusters at the same time, I find messages like this on the second node of the Dev Cluster:

       

      WARN  [org.jgroups.protocols.UDP] discarded message from different group "Tomcat-Cluster" (our group is "Tomcat-Acceptance"). Sender was <IP_OF_SECOND_PROD_NODE>:9962

       

      and

       

      WARN   2011-05-11 11:08:12,447 ViewHandler org.jgroups.protocols.pbcast.GMS.castViewChangeWithDest failed to collect all ACKs (1) for view [<IP_OF_SECOND_DEV_NODE>:9770|2] [<IP_OF_SECOND_PROD_NODE>:9970] after 2000ms, missing ACKs from [<IP_OF_SECOND_PROD_NODE>:9970] (received=[<IP_OF_SECOND_DEV_NODE>:9770]), local_addr=<IP_OF_SECOND_DEV_NODE>:9770

       

      The same warnings could be found on the second node of the Prod Cluster with the IP adress form the second node of the Dev system.

      I know that this are only warning, but the bad thing is, that after 2 hours our Application on Prod hangs with the following messages:

       

      The cache caused an exception.

      ...

      Caused by: org.jboss.cache.ReplicationException: rsp=sender=<IP_OF_SECOND_PROD_NODE>:9547, retval=null, received=false, suspected=false

      ...

      Caused by: org.jboss.cache.lock.TimeoutException: Response timed out: sender=<IP_OF_SECOND_PROD_NODE>:9547, retval=null, received=false, suspected=false

       

      After stopping the second node from the Dev system, our Application continues working. It seems the reason for this is that both second nodes of each Cluster still talk to each other.

       

      Anyone an idea how and where to disable this?

       

      Thanks in advance,

      Jens