3 Replies Latest reply on Aug 12, 2011 7:22 PM by Carlton Schuyler

    support for remote tomcat 6 ?

    Przemek Wiktor Newbie

      Hello

       

       

      First of all - thanks Aslak for the presentation on last Geecon in Krakow !

       

      I have a question - when can we expect support for remote tomcat 6 ?

       

      Or is it possible to run some integration tests on already deployed/started tomcat container ?  I cannot use embedded tomcat as my application requires another one doployed together on one tomcat...

      Or maybe it is already possible ?  I found in (http://docs.jboss.org/arquillian/reference/latest/en-US/html_single/#container.tomcat-embedded-6 )  that there is a property tomcatHome ? it is relevant to my setup ?

       

      <property name="tomcatHome">target/tomcat-embedded-6-standby</property> 

       

       

       

      thanks in advance for any help

      Przemek

        • 1. support for remote tomcat 6 ?
          Aslak Knutsen Master

          Never actually tried to point tomcatHome to a existing tomcatHome, but it might work in your case.

           

          Ondra is working on a tomcat-remote-6 container that can be found here: https://github.com/OndraZizka/arquillian-container-tomcat/tree/master/tomcat-remote-6 , it is a bit off sync with a current arquillian-core, but i believe it should run against Alpha5 if you update the pom a bit..

          • 2. Re: support for remote tomcat 6 ?
            Przemek Wiktor Newbie

            I finally was able to set up test environment based on Ondra's plugin and it works pretty good

             

            (and indeed pom had to be slightly updated)

            • 3. Re: support for remote tomcat 6 ?
              Carlton Schuyler Newbie

              Hi Wiktor,

               

              I am also trying to use Ondra's arquillian-tomcat-remote-6 container.  Could you share what your pom updates needed to be?  At the moment I'm using the following:

               

                      <dependency>

                          <groupId>org.jboss.arquillian</groupId>

                          <artifactId>arquillian-api</artifactId>

                          <version>1.0.0.Alpha5</version>

                      </dependency>

               

                      <dependency>

                          <groupId>org.jboss.arquillian</groupId>

                          <artifactId>arquillian-testng</artifactId>

                          <version>1.0.0.Alpha5</version>

                      </dependency>

                     

                      <dependency>

                          <groupId>org.jboss.shrinkwrap</groupId>

                          <artifactId>shrinkwrap-impl-base</artifactId>

                          <version>1.0.0-alpha-5</version>

                      </dependency>

               

                      <dependency>

                          <groupId>org.jboss.shrinkwrap</groupId>

                          <artifactId>shrinkwrap-extension-tomcat-6</artifactId>

                          <version>1.0.0-beta-1-SNAPSHOT</version>

                       </dependency>

               

              and getting this error when running an Arquillian test:

               

              ...

              Caused by: java.lang.ClassNotFoundException: org.jboss.shrinkwrap.api.Asset

              ...

               

              (I elided most of the stck trace; hoping the one line above will trigger your memory)