2 Replies Latest reply on May 17, 2011 4:03 AM by Richard Kennard

    How to specify 'Server Locations' for JBoss AS like I can for Tomcat?

    Richard Kennard Novice

      Hi guys,

       

      Thanks for all your hard work on JBoss Tools! I use it every day and it gives me a real boost.

       

      I'm trying to configure the location for JBoss to deploy WARs when running inside Eclipse. Under my 'Servers' tab if I click on, say, a Tomcat instance there is a part of the properties page called 'Server Locations'. Under there, I can specify (among other things) 'Use Tomcat installation' (instead of 'Use workspace metadata') which deploys to the usual /tomcat/webapps folder.

       

      But if I double click a JBoss server there is no such option. I seem to only be able to configure a location of '[workspace metadata]' or '/Servers/JBoss 6'. This is a problem on Windows, because both these locations are under /Program Files, and JBoss AS 6 does not like spaces in folder paths. I get this error:

       

      17:10:08,769 ERROR [org.jboss.kernel.plugins.dependency.AbstractKernelController] Error installing to Start: name=jboss.web.deployment:war=/avant-ss state=Create mode=Manual requiredState=Installed: java.net.URISyntaxException: Illegal character in path at index 16: file:/N:/Program Files/Eclipse/workspace/.metadata/.plugins/org.jboss.ide.eclipse.as.core/JBoss_6.0_Runtime_Server1305600327383/deploy/my.ear/my-web.war/

       

      Is there a workaround? Should I open a JIRA?

       

      Richard.