1 Reply Latest reply on May 24, 2011 3:58 AM by Hootan V

    RichFace Compatibility Issue

    Hootan V Newbie

      Hi Experts,

       

      We're using JSF 1.2 and RichFace 3.3.3.Final accompanying with tomahawk 1.1.6 , jQuery ,

      myfaces-1.2.9, and tomahawk-sandbox-1.1.7.

       

      I've added a rich:SuggestionBox to a page but when the page loads there are 2 errors:

       

      Message: Object doesn't support this property or method

      Line: 265

      Char: 107

      Code: 0

      URI: http://localhost:8080/persianGulf/a4j/g/3_3_3.Finalorg.ajax4jsf.javascript.PrototypeScript.jsf

       

      Message: Object doesn't support this property or method

      Line: 16

      Char: 26

      Code: 0

      URI: http://localhost:8080/persianGulf/a4j/g/3_3_3.Finalscripts/suggestionbox.js.jsf

       

      I overwrote prototype.js in tomahawk-1.1.6.jar from RF but no changes.

      Also the following workarounds applied but no luck yet.

       

      <a4j:loadScript src="resource://org.ajax4jsf.javascript.PrototypeScript" />

       

      Web.xml configs:

       

      <context-param>

              <param-name>org.ajax4jsf.LoadScriptStrategy</param-name>

              <param-value>NONE</param-value>

      </context-param>

      <context-param>

          <param-name>org.ajax4jsf.ExcludeScripts</param-name>

          <param-value>Prototype,Scriptaculous</param-value>

      </context-param>

       

      When I use <a4j:loadScript src="resource://prototype.js" /> in the page, the first Prototype error is gone, but the suggestion box doesn't work properly with throwing another error:

       

      Message: Object doesn't support this property or method

      Line: 29

      Char: 1006

      Code: 0

      URI: http://localhost:8080/persianGulf/a4j/g/3_3_3.Finalorg/richfaces/renderkit/html/scripts/scriptaculous/effects.js.jsf

       

      I would be thankful if someone could help me out with this.

        • 1. Re: RichFace Compatibility Issue
          Hootan V Newbie

          Problem solved.

           

          We had loaded a different version of jQuery in the page from that of the RF.

           

          jquery.js was removed from our scripts folder and added to richface3.3.3Final-impl.jar which subsequently imported by the following code in our page:

           

          <a4j:loadScript src="resource:///org/richfaces/renderkit/html/scripts/jquery/jquery.js"></a4j:loadScript>

           

          Also tomahawk prototype.js updated with the RF one.

          Hope this will help others having the same problem.