0 Replies Latest reply on Jun 1, 2011 4:58 AM by Gabriele Pezzini

    Endpoint does not contain operation meta data for Exception

    Gabriele Pezzini Newbie

      Hi all,

      I have deployed a web services in JBoss 4.2.3 GA jdk6, and I run JBoss using Jdk 6

      I have generated the artifatcs using wsconsume and I have build a client to invoke my service.
      If I invoke the service from a wm outside jboss, all goes well: my service is invoke and performs its job,

      that means that wsdl, mapping and so on are fine.

       

      But I need also to invoke the same service inside a JBoss's thread that polls on db and invokes the service.

      To do so I have put the same artifact and the ws client in a jar located in .../WEB-INF/lib folder., and my thread

      invokes for the client.

       

      When ws is invoked I have the "Endpoint does not contain operation meta data for Exception" in JBoss log.

       

      After some works around it, I have see that I use the same client outside JBoss, I have two scenarios:
      1) If I run my vm without nothing in classpath the services (JBoss side) is invoked and performs its job

      2) If I run my vm within the same classpath setted by wsconsume (that uses some JBoss's jars) I have the same exception

          that I have running the client inside a JBoss's thread.

         

      So I Imagine that are there some jars issue, so I have installed a clean JBoss 4.2.3 GA jdk6, within only my web service to test;

      but nothing change: within the JBoss's jars in classpath (the one setted by wsconsume) I have always the exception and without

      the jars all works fine.

       

      So:

      Are there some config to do to solve my problem?

      Is there a way to call my service inside a JBoss's thread (that obviously has the JBoss's jar in class path)?

       

       

      Thank you very much