0 Replies Latest reply on Jun 7, 2011 11:34 AM by Benjamin Maisano

    JAX-WS 2.1 support on JBoss AS 5.0.1

    Benjamin Maisano Newbie

      Hi, I'm trying to generate a java client from a WSDL file using Eclipse Helios.  I've done latest updates for all plugins, (ie JWT, JBoss Tools, etc).  I right click the wsdl file and select "web services >> generate client" and a wizard launches and has me select several things, one of which being the jax-ws runtime, and I have selected JbossWS.  From this site I found a post with a link showing the table, telling me JBoss AS 5.0.1 has JbossWS 3.1.x support.  I also found a post stating JbossWS 3.1 supports JAX-WS 2.1.  However, when I select JAX-WS 2.1 in the wizard I get the following error:

       

      Error: Could not import. (use --verbose to see full traces)
      java.lang.IllegalArgumentException: WSConsume (native) only supports JAX-WS 2.0
      at org.jboss.ws.tools.jaxws.impl.SunRIConsumerImpl.consume(SunRIConsumerImpl.java:202)
      at org.jboss.wsf.spi.tools.cmd.WSConsume.importServices(WSConsume.java:222)
      at org.jboss.wsf.spi.tools.cmd.WSConsume.main(WSConsume.java:80)

       

      If I select JAX-WS 2.0 the operation completes successfully and generates a bunch of java classes.  Can someone explain please....any help is grealty appreciated.