13 Replies Latest reply on Jul 25, 2011 2:31 AM by Jean-Frederic Clere

    JBoss 4.3.0.GA_CP08/mod_jk 1.2.31/RHEL 5.5 64bit/HTTPD 2.2.3 - awaited reply cpong, received 3 instead

    Eugene K Newbie

      mod_jk.log:

       

       

      [Tue Jun 14 11:23:01 2011][5877:47828542595840] [warn] ajp_handle_cping_cpong::jk_ajp_common.c (906): awaited reply cpong, received 3 instead. Closing connection

      [Tue Jun 14 11:23:01 2011][5877:47828542595840] [info] ajp_send_request::jk_ajp_common.c (1511): (app01_21) failed sending request, socket -1 prepost cping/cpong failure (errno=0)

      [Tue Jun 14 11:23:01 2011][5877:47828542595840] [info] ajp_send_request::jk_ajp_common.c (1567): (app01_21) all endpoints are disconnected, detected by connectcheck (0), cping (1), send (0)

       

       

       

      Found the description:

       

      "The JBoss server in that case sended an additional response packet of size 0 after the final response packet. That's a protocol violation. When mod_jk sends a cping in front of the next request, JBoss answers correctly with a cpong, but mod_jk reading from the network buffer first gets the empty response packet left over from the previous response and complains, because it's not the cpong packet."

       

       

      I guess we hit https://issues.apache.org/bugzilla/show_bug.cgi?id=49929. There is a fix for tomcat http://svn.apache.org/viewvc?view=revision&revision=1066772. Could JBoss Web mainterners comment on this? Thanks in advance.

       

      PS We have also tried  to use JBoss Web Native Connectors 2.0.9 with no luck - the same behaviour.