10 Replies Latest reply on Jun 16, 2011 1:26 AM by marsch

    problem with shutdown

    Newbie

      hi,

       

      i got a problem to shutdown my jboss server.

      this is the error message:

      vwREDHAT_greenshot_2011-06-14_14-15-03.jpg

       

      it is a redhat enterprise 5 system , java is 1.6.0_20.

       

      i changed the parameter in the .bash_profile of the JAVA_HOME and checked it, it is correct.

      but now i can't close the server but i need to...

       

      thnx a lot!

        • 1. Re: problem with shutdown
          Wolf-Dieter Fink Master

          Looks like that the grep command fail within the shell script.

          Maybe the IP address is wrong for the shutdown call.

           

          Could you check whether the IP address is wrong?

          Also if you call 'set -x' befor you start the script you might get helpful hints.

          • 2. Re: problem with shutdown
            Newbie

            hallo wolf-dieter fink,

             

            ich nehme an, sie sind aus deutschland...

            die ip stimmt, der server hat die ip-adresse, die hier ausgegeben wird.

             

            zum set-x - wie lautet der gesamte befehl? denn was auch immer ich angebe, erhalte ich command not found. auch wenn ich nur set-x oder set-x und danach den befehl zum shutdown absetze, gleiche fehlermeldung.

             

            ich bin halt ein beginner und installiere meine erste jboss anwendung.

             

            danke!

            • 3. Re: problem with shutdown
              Wolf-Dieter Fink Master

              Vielleicht stimmt der port 1099 nicht?

              'set -x' ist ein Unix Kommando und setzt die Shell auf DEBUG, einfach vor dem eigentlichen Kommando eingeben (set +x stellt es wieder zurück )

               

              Das init script holt JAVA_HOME auf diese Weise.

              Ausserdem ist es für den Einsatz unter /etc/init.d vorgesehen.

               

              Vielleicht einfach mal shutdown.sh -s <host>:<port> ausprobieren

               

              PS: besser in englisch damit der Rest der community auch was davon hat

              • 4. Re: problem with shutdown
                Newbie

                thnx, it could be the port. i changed it while the installation in the config on the port 8180. how can i change it for the shutdown?

                 

                i tried the following command: ./shutdown -s <IP>:<Port> - it caused the same error message!

                 

                it is nessesary to run the jboss with 8180!

                • 5. Re: problem with shutdown
                  Wolf-Dieter Fink Master

                  How do you install the JBoss and what version (EAP or community of 5.1) do you have?

                  I suppose you change the 8080 port to 8180, this is not the JNDI port (default 1099).

                   

                  Do you change other ports? How do you start? with the port-binding and offset of port-01 (100),

                  Then you should try 1199 instead of 1099

                  • 6. Re: problem with shutdown
                    Newbie

                    i have the 5.1.0 installed.

                    in the ./jboss_init_redhat.sh i have the following changes:

                     

                    #define the script to use to start jboss

                    JBOSSSH=${JBOSSSH:-"$JBOSS_HOME/bin/run.sh -c $JBOSS_CONF -b $JBOSS_HOST -Djboss.service.binding.set=ports-01"}

                     

                    thats the only change i made for jboss.

                    and than i start the jboss_init_redhat.sh with start.

                     

                    i defined the follwing things in the .bash_profile:

                    JBOSS_USER=eessiusr

                    export JBOSS_USER

                     

                    JBOSS_CONF=default

                    export JBOSS_CONF

                     

                    JBOSS_HOST=<IP>

                    export JBOSS_HOST

                     

                    export PATH

                     

                    thnx.

                    • 7. Re: problem with shutdown
                      Wolf-Dieter Fink Master

                      In this case, test

                      shutdown.sh -s <IP>:1199

                      • 8. Re: problem with shutdown
                        Newbie

                        sorry... but its still the same problem...

                        • 9. Re: problem with shutdown
                          Wolf-Dieter Fink Master

                          Use your browser with 'http://<IP>:8180'.

                          Navigate to

                          - jmx-console

                          - select 'jboss' under "Object Name Filter"

                          - select "service=naming"

                           

                          If you look for 'BindAddress' and 'Port' you will see the parameter for shutdown that should work.

                          If it doesn't work you might have a networking problem (routing, firewall etc.)

                           

                          For unix it is also posible to stop the JBoss with a standard 'kill <PID> signal, this will start also a graceful shutdown.

                          • 10. Re: problem with shutdown
                            Newbie

                            hi... at the moment works nothing.. don't know what happend, but i can't reach the jboss, its starts with error messages and i have to install it new...