3 Replies Latest reply on Jun 23, 2011 4:15 PM by Wolf-Dieter Fink

    New to JBoss - problem with clusters

    Andy Knott Newbie

      Evening

       

      Im a college student who is studying integrsation patterns, and want to look to practice some of my skills using the JBoss application server - so I've download the version 6 product.

       

      Whilst I've got he basic server working, I'm struggling to  find detailed resources about how to configure JBoss correctly.

       

      I've installed 2 VMs and I've installed Apache with mod_jk, and I'm trying to get clustering to work -however when I try to start JBoss on two different machines I get the following errors message continually appearing - which I know are related to the hornetq component (which is related to messaging that I'm notusing at this stage)

       

      2011-06-21 18:35:06,984 WARN  [org.hornetq.core.cluster.impl.DiscoveryGroupImpl] (hornetq-discovery-group-thread-dg-group1) There are more than one servers on the network broadcasting the same node id. You will see this message exactly once (per node) if a node is restarted, in which case it can be safely ignored. But if it is logged continuously it means you really do have more than one node on the same network active concurrently with the same node id. This could occur if you have a backup node active at the same time as its live node.

       

      Now I have started the Jboss instance using the command

       

      run -c all -b 'IP address' -djboss.messaging.serverpeerid=1 on the first node, and peerid=2 on the second node (these are running on W2008 servers).

       

      Can someone please clarify:

       

      - if there is a simple way of setting different node IDs in an XML file - and clarify which XML file this should be - on the basis that I'm using JBoss 6.0.0.

      - is there a simple way of disabling the hornetq component, since I don't need it at this stage?

       

      Any help would be gratefully appreciated - as I've spent all day on this.

       

      Thanks