0 Replies Latest reply on Jun 23, 2011 2:22 AM by Veit Ullmann

    build tests in testsuite fails

    Veit Ullmann Newbie

      I checked out jboss as 6 from http://anonsvn.jboss.org/repos/jbossas/trunk and executed build,

      executed build in testsuite and then started build tests in testsuite.

       

      I got the following error:

       

      jboss-all-config-tests:

      [server:start] Starting server "all", with command (start timeout is 120 seconds ):

      [server:start] D:\Java\jdk1.6\bin\java -cp D:\jboss_svn\as\build\target\jboss-6.1.0-SNAPSHOT\bin\run.jar;D:\Java\jdk1.6\lib\tools.jar -Xms128m -Xmx512m -XX:MaxPermSize=512m -XX:+HeapDumpOnOutOfMemoryE

      rror -XX:-UseGCOverheadLimit -Djava.net.preferIPv4Stack=true -Djava.net.preferIPv6Addresses=true -Djava.endorsed.dirs=D:\jboss_svn\as\build\target\jboss-6.1.0-SNAPSHOT/lib/endorsed -Dlogging.configura

      tion=file:D:\jboss_svn\as\build\target\jboss-6.1.0-SNAPSHOT/bin/logging.properties -Djgroups.udp.ip_ttl=0 -Dnaming.autodiscovery.mcast_addr=230.9.9.9 -Djboss.server.log.threshold=DEBUG -Djboss.boot.se

      rver.log.level=DEBUG -Djava.endorsed.dirs=D:\jboss_svn\as\build\target\jboss-6.1.0-SNAPSHOT/lib/endorsed/ -Dxb.builder.useUnorderedSequence=true org.jboss.Main -c all -b localhost -g DefaultPartition

       

      [server:start] Server started.

           [echo] Using node0=localhost,node0.http.url=http://localhost:8080,node0.jndi.url=jnp://localhost:1099

           [echo] Using node1=T510,node1.http.url=http://T510:8080,node1.jndi.url=jnp://T510:1099

           [echo] Using java.net.preferIPv4Stack=true,java.net.preferIPv6Addresses=true

       

      check-env:

       

      init-maven-ant-tasks:

       

      init-dependencies:

       

      init-paths:

       

      server-config:

       

      init:

       

      tests-standard-unit:

           [echo]

           [echo]    junit.timeout:              300000

           [echo]    jbosstest.iterationcount:   10

           [echo]    jbosstest.threadcount:      5

           [echo]    jbosstest.beancount:        5

           [echo]

          [junit] Running org.jboss.test.aop.test.AOPUnitTestCase

          [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0 sec

       

      BUILD FAILED

      D:\jboss_svn\as\testsuite\build.xml:1310: The following error occurred while executing this line:

      D:\jboss_svn\as\testsuite\build.xml:1375: The following error occurred while executing this line:

      D:\jboss_svn\as\testsuite\build.xml:1806: Process fork failed.

       

      Total time: 1 minute 32 seconds

      Testsuite shutdown hook found server "all" still running; stopping it.

      Shutting down server: all

      log4j:WARN No appenders could be found for logger (org.jnp.interfaces.TimedSocketFactory).

      log4j:WARN Please initialize the log4j system properly.

      shutdownTimeout will be=45

      Server stopped.

       

      What do I have to do?