0 Replies Latest reply: Jun 23, 2011 4:40 AM by Federico Ceccarini RSS

    Trouble in Dynamic Endpoint Reference

    Federico Ceccarini Newbie

      Hi,

      I have some problem using the Dynamic Endpoint Reference assign. I'm trying to change the partnerLink endpoint using the following bpel assign form:

       

      <bpel:assign name="assignChangeServiceEndpoint">

      <bpel:copy>

        <bpel:from>

        <bpel:literal>http://localhost:8080/goal2problemSubplan</bpel:literal>

      </bpel:from>

      <bpel:to partnerLink="goal2problemPlanSubplanPartnerLink"/>

      </bpel:copy>

       

      No error was raised but the assign doesn't have effect to the invoke activity. (the new endpoint wasn't call).

       

      I have the same result if I use the assign form:

       

      <bpel:copy>

      <bpel:from variable="myInputControlVar" part="control">

      <bpel:query queryLanguage="urn:oasis:names:tc:wsbpel:2.0:sublang:xpath1.0">mainflow:Address</bpel:query>

      </bpel:from>

      <bpel:to variable="partnerLinkAddress"/>

      </bpel:copy>

      <bpel:copy>

      <bpel:from>$partnerLinkAddress<bpel:form>

      <bpel:to partnerLink="goal2problemPlanSubplanPartnerLink"/>

      </bpel:copy>

       

      Where the variable partnerLinkAddress is a string

       

      <bpel:variable xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"

                           xmlns:xsd="http://www.w3.org/2001/XMLSchema"

      name="partnerLinkAddress"

      type="xsd:string"/>

       

      But if I use the following form:

       

                          <bpel:copy>

                                             <bpel:from variable="myInputControlVar" part="control">

                                                <bpel:query queryLanguage="urn:oasis:names:tc:wsbpel:2.0:sublang:xpath1.0">mainflow:Address</bpel:query>

      </bpel:from>

                                             <bpel:to variable="partnerLinkAddress"/>

      </bpel:copy>

      <bpel:copy>

                                             <bpel:from variable="partnerLinkAddress"/>

                                             <bpel:to partnerLink="goal2problemPlanSubplanPartnerLink"/>

      </bpel:copy>

       

      The following error is raised:

       

      2011-06-23 09:30:29,646 WARN [org.apache.ode.bpel.epr.EndpointFactory] (ODEServer-10) Couldnt create any endpoint for element <?xml version="1.0" encoding="UTF-8"?>

      <service-ref xmlns="http://docs.oasis-open.org/wsbpel/2.0/serviceref"><temporary-simple-type-wrapper xmlns="">http://localhost:9081/goal2problemSubplan</temporary-simple-type-wrapper></service-ref>

       

       

      Do you have any suggest? Do you know where am I in wrong?

       

      Thanks for your help.

       

      I'm using the following environment:

       

      O.S : Windows Vista

      JBoss jboss-5.1.0.GA

      Java jdk6

      No JBoss ESB Installed

      DB: MySQL/hsql

      Riftsaw: riftsaw 2.3.0-SNAPSHOT (371)

       

      Federico