1 Reply Latest reply on Jun 24, 2011 7:03 PM by krisverlaenen

    5.1 final full installer Ant error on Mac


      Thanks so much for releasing this.


      Working my way down the documentation with the full installer 'ant install.demo' worked the first time but 'ant start.demo' failed at line 488.

      <exec executable="${eclipse.home}/eclipse" spawn="yes" osfamily="unix">

      I changed it to

      <exec executable="${eclipse.home}/eclipse" spawn="yes" os="Linux">

      like it was in a previous version and it worked


      Mac isn't Linux so that block won't execute but it is unix so it's executed in the final script and that's an error.

        • 1. Re: 5.1 final full installer Ant error on Mac

          Thank you for reporting this.  It indeed seems the case that osfamily="unix" also applies to Mac, so changing that (back) to os="Linux" indeed should solve this issue. 


          It's probably best to also remove the osfamily="mac" in the start.jboss and stop.jboss targets to avoid duplicate triggering (although this probably doesn't prevent the installer from working).