5 Replies Latest reply on Jun 28, 2011 3:46 AM by Hans Wolffenbuttel

    Even after disabling INVM Transport, ServiceInvoker still warns about Unresposive InVM EPRs

    VINESH PEMMADA Newbie

      Environment:

       

      JBossESB 4.5 running on JBoss AS 4.2.3

       

       

      Problem Description:

       

      We are in process of migrating to JBossESB 4.5 on JBoss AS 4.2.3 from JBossESB 4.2 running on JBoss AS 4.0.5.

       

      All services are configured with JMS listener. 

       

      We disabled InVM Transport, by setting "jboss.esb.invm.scope.default" to "NONE".

       

      Service invoker is able to invoke the services using JMS. But it always prints below trace about InVM EPRs.

       

       

      2011-06-23 20:15:07,678 WARN  [org.jboss.soa.esb.client.ServiceInvoker] (pool-107-thread-3) Possible configuration error while using Courier for EPR [InVMEpr [ PortReference < <wsa:Address invm://4465787472436f6e74656e745365727669636573242424242424242424242424436f6e74656e745175657279506c7567696e/false?false#10000/>, <wsa:ReferenceProperties jbossesb:passByValue : false/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/invm/> > ]] and Service [DextrContentServices:ContentQueryPlugin] and Message [header: [ To: InVMEpr [ PortReference < <wsa:Address invm://4465787472436f6e74656e745365727669636573242424242424242424242424436f6e74656e745175657279506c7567696e/false?false#10000/>, <wsa:ReferenceProperties jbossesb:passByValue : false/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/invm/> > ] ]]. No deliverAsync courier

      2011-06-23 20:15:07,678 INFO  [org.jboss.soa.esb.client.ServiceInvoker] (pool-107-thread-3) Unresponsive EPR: InVMEpr [ PortReference < <wsa:Address invm://4465787472436f6e74656e745365727669636573242424242424242424242424436f6e74656e745175657279506c7567696e/false?false#10000/>, <wsa:ReferenceProperties jbossesb:passByValue : false/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/invm/> > ] for message: header: [  ]

      2011-06-23 20:15:10,732 WARN  [org.jboss.soa.esb.client.ServiceInvoker] (http-166.77.14.230-9210-1) Possible configuration error while using Courier for EPR [InVMEpr [ PortReference < <wsa:Address invm://4465787472436f6e74656e7453657276696365732424242424242424242424244e6f746966794665656452657175657374576f726b666c6f77417761726553657276696365/false?false#10000/>, <wsa:ReferenceProperties jbossesb:passByValue : false/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/invm/> > ]] and Service [DextrContentServices:NotifyFeedRequestWorkflowAwareService] and Message [header: [ To: InVMEpr [ PortReference < <wsa:Address invm://4465787472436f6e74656e7453657276696365732424242424242424242424244e6f746966794665656452657175657374576f726b666c6f77417761726553657276696365/false?false#10000/>, <wsa:ReferenceProperties jbossesb:passByValue : false/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/invm/> > ] ]]. No deliverAsync courier

      2011-06-23 20:15:10,733 INFO  [org.jboss.soa.esb.client.ServiceInvoker] (http-166.77.14.230-9210-1) Unresponsive EPR: InVMEpr [ PortReference < <wsa:Address invm://4465787472436f6e74656e7453657276696365732424242424242424242424244e6f746966794665656452657175657374576f726b666c6f77417761726553657276696365/false?false#10000/>, <wsa:ReferenceProperties jbossesb:passByValue : false/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/invm/> > ] for message: header: [  ]

       

       

       

      It looks like even after disabling InVM Transport, ServiceInvoker still tries to use the InVM EPRs.

       

      My  jbossesbproperties.xml looks as below.

       

       

      <esb xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="jbossesb-1_0.xsd">

          <properties name="core">

              <property name="org.jboss.soa.esb.jndi.server.context.factory" value="org.jnp.interfaces.NamingContextFactory"/>

              <property name="org.jboss.soa.esb.jndi.server.url" value="${jboss.bind.address}:${jboss.ha.naming.port}"/>

              <property name="org.jboss.soa.esb.persistence.connection.factory" value="org.jboss.internal.soa.esb.persistence.format.MessageStoreFactoryImpl"/>

              <property name="org.jboss.soa.esb.loadbalancer.policy" value="org.jboss.soa.esb.listeners.ha.RoundRobin"/>

              <property name="jboss.esb.invm.scope.default" value="NONE"/>

          </properties>

          <properties name="registry">

              <property name="org.jboss.soa.esb.registry.queryManagerURI" value="org.apache.juddi.registry.local.InquiryService#inquire"/>

              <property name="org.jboss.soa.esb.registry.lifeCycleManagerURI" value="org.apache.juddi.registry.local.PublishService#publish"/>

              <property name="org.jboss.soa.esb.registry.implementationClass" value="org.jboss.internal.soa.esb.services.registry.JAXRRegistryImpl"/>

              <property name="org.jboss.soa.esb.registry.factoryClass" value="org.apache.ws.scout.registry.ConnectionFactoryImpl"/>

              <property name="org.jboss.soa.esb.registry.user" value="jbossesb"/>

              <property name="org.jboss.soa.esb.registry.password" value="password"/>

              <!-- the following parameter is scout specific to set the type of communication between scout and the UDDI (embedded, rmi, soap) -->

              <property name="org.jboss.soa.esb.scout.proxy.transportClass" value="org.apache.ws.scout.transport.LocalTransport"/>

              <!-- specify the interceptors, in order -->

              <!-- <property name="org.jboss.soa.esb.registry.interceptors" value="org.jboss.internal.soa.esb.services.registry.InVMRegistryInterceptor"/>-->

              <!--

               Example of specifying multiple registry interceptors

              <property name="org.jboss.soa.esb.registry.interceptors" value="org.jboss.internal.soa.esb.services.registry.InVMRegistryInterceptor, org.jboss.internal.soa.esb.services.registry.CachingRegistryInterceptor"/>

              -->

              <!--<property name="org.jboss.soa.esb.registry.interceptors" value="org.jboss.internal.soa.esb.services.registry.CachingRegistryInterceptor"/>-->

              <!-- The following properties modify the cache interceptor behaviour -->

              <property name="org.jboss.soa.esb.registry.cache.maxSize" value="100"/>

              <property name="org.jboss.soa.esb.registry.cache.validityPeriod" value="600000"/>

          </properties>

          <properties name="transports" depends="core">

              <property name="org.jboss.soa.esb.mail.smtp.host" value="localhost"/>

              <property name="org.jboss.soa.esb.mail.smtp.user" value="jbossesb"/>

              <property name="org.jboss.soa.esb.mail.smtp.password" value=""/>

              <property name="org.jboss.soa.esb.mail.smtp.port" value="25"/>

              <property name="org.jboss.soa.esb.mail.smtp.auth" value="true"/>

              <property name="org.jboss.soa.esb.ftp.localdir" value="/tmp"/>

              <property name="org.jboss.soa.esb.ftp.remotedir" value="/tmp"/>

              <property name="org.jboss.soa.esb.jms.connectionPool" value="100"/>

              <property name="org.jboss.soa.esb.jms.sessionSleep" value="30"/>

              <!--  Uncomment this to return stack traces when exposing an ESB service through WS

              <property name="org.jboss.soa.esb.ws.returnStackTrace" value="true"/>

              -->

              <!--  Uncomment this to specify the WS response timeout when exposing an ESB service through WS

              <property name="org.jboss.soa.esb.ws.timeout" value="30000"/>

              -->

          </properties>

          <properties name="connection">

              <property name="min-pool-size" value="5"/>

              <property name="max-pool=size" value="10"/>

              <property name="blocking-timeout-millis" value="5000"/>

              <property name="abandoned-connection-timeout" value="10000"/>

              <property name="abandoned-connection-time-interval" value="30000"/>

          </properties>

          <properties name="dbstore">

              <!--  connection manager type -->

              <property name="org.jboss.soa.esb.persistence.db.conn.manager" value="org.jboss.internal.soa.esb.persistence.manager.J2eeConnectionManager"/>

              <!-- this property is only used if using the j2ee connection manager -->

              <property name="org.jboss.soa.esb.persistence.db.datasource.name" value="java:/JBossESBDS"/>

              <!--table managed by pool to test for valid connections - created by pool automatically -->

              <property name="org.jboss.soa.esb.persistence.db.pool.test.table" value="pooltest"/>

              <property name="org.jboss.soa.esb.persistence.db.pool.timeout.millis" value="5000"/>

          </properties>

          <properties name="filters">

              <property name="org.jboss.soa.esb.filter.1" value="org.jboss.internal.soa.esb.message.filter.MetaDataFilter"/>

              <property name="org.jboss.soa.esb.filter.2" value="org.jboss.internal.soa.esb.message.filter.GatewayFilter"/>

          </properties>

      </esb>

       

       

       

       

      As InVm Transport is not required for us, We want to make ServiceInvoker not to bother about InVM EPRs.

       

      How can we findout what is wrong with the configurations we made?