3 Replies Latest reply on Jul 5, 2011 3:36 AM by Max Rydahl Andersen

    what is difference between m2elipse + m2e-wtp and JBT Maven Support

    duc tun vu Newbie

      Hi,

      im new to Seam and JBT, i want to use JBoss Tool für mavenized seam project, but i dont know which plugins and in which order they should be installed for  proper working.

       

      Until now i has been using m2elipse plugin for not-JEE maven projects and plus m2e-wtp (from m2e-extras repo) for mavenized JEE-Projects (they were not Seam projecst).

       

      But when one browsing the JBT 3.3 DEV repo for Eclipse 3.7 (or 3.2 for eclipse 3.6), beside JBT plugin one also sees the "Maven Support" plugin. I figured out, in eclipse 3.6 + JBT 3.2 one can have both plugins JBoss Maven Support and m2eclipse, but not in Eclipse 3.7 + JBT 3.3 M2. I received this error message when trying to install JBoss Maven Support:

       

      Cannot complete the install because of a conflicting dependency.

        Software being installed: JBoss Maven JSF Configurator 1.2.0.v20110624-0731-H5-M2 (org.jboss.tools.maven.jsf.feature.feature.group 1.2.0.v20110624-0731-H5-M2)

        Software currently installed: Maven Integration for Eclipse (Required) 0.12.1.20110112-1712 (org.maven.ide.eclipse.feature.feature.group 0.12.1.20110112-1712)

      Only one of the following can be installed at once:

          This version of m2eclipse cannot be installed on top of the already installed m2eclipse. Uninstall the previous version of m2eclipse and try the install again. 1.0.0.201106061504 (org.maven.ide.eclipse 1.0.0.201106061504)

          Maven Integration for Eclipse 0.12.1.20110112-1712 (org.maven.ide.eclipse 0.12.1.20110112-1712)

          This version of m2eclipse cannot be installed on top of the already installed m2eclipse. Uninstall the previous version of m2eclipse and try the install again. 1.0.0.20110607-2117 (org.maven.ide.eclipse 1.0.0.20110607-2117)

          This version of m2eclipse cannot be installed on top of the already installed m2eclipse. Uninstall the previous version of m2eclipse and try the install again. 0.13.0.201105171436 (org.maven.ide.eclipse 0.13.0.201105171436)

        Cannot satisfy dependency:

          From: M2E - Maven Integration for Eclipse (Incubation) 0.13.0.201105171436 (org.eclipse.m2e.feature.feature.group 0.13.0.201105171436)

          To: bundle org.maven.ide.eclipse [0.13.0.201105171436]

        Cannot satisfy dependency:

          From: m2e - Maven Integration for Eclipse 1.0.0.201106061504 (org.eclipse.m2e.feature.feature.group 1.0.0.201106061504)

          To: bundle org.maven.ide.eclipse [1.0.0.201106061504]

        Cannot satisfy dependency:

          From: m2e - Maven Integration for Eclipse 1.0.0.20110607-2117 (org.eclipse.m2e.feature.feature.group 1.0.0.20110607-2117)

          To: bundle org.maven.ide.eclipse [1.0.0.20110607-2117]

        Cannot satisfy dependency:

          From: JBoss Maven JSF Configurator 1.2.0.v20110624-0731-H5-M2 (org.jboss.tools.maven.jsf.feature.feature.group 1.2.0.v20110624-0731-H5-M2)

          To: org.eclipse.m2e.feature.feature.group 0.13.0

        Cannot satisfy dependency:

          From: Maven Integration for Eclipse (Required) 0.12.1.20110112-1712 (org.maven.ide.eclipse.feature.feature.group 0.12.1.20110112-1712)

          To: org.maven.ide.eclipse [0.12.1.20110112-1712]

      ---------------------------------------------------------------------------------------------------------------------

       

      Now i dont know, what should i pick (m2eclipse vs. JBoss Maven Support), for Eclipse 3.7 + JBT 3.3 what is preferred, and how they differ from each other?

       

      Thank you very much!