0 Replies Latest reply on Jul 4, 2011 6:04 PM by Joel Goldberger

    Looking for working GF/JPA example with latest snapshot

    Joel Goldberger Newbie

      I am trying to find a working example that incorporates JPA running under embedded-glassfish-3.1.  I have pulled down the latest snapshot via:

       

      git clone git://github.com/arquillian/arquillian.git arquillian

       

      I then tried "cd examples/testng; mvn test -Pglassfish-embedded-3.1", but that only runs the ejb and cdi tests, and only the ejb tests seem to pass.  I modified the pom and added <include>jpa/8</include> but it fails to initialize the container.

       

      I have also looked at http://nosoftskills.com/2011/01/unit-testing-services-arquillian/ which had a working example using Alpha4, but the configuration setup has obviously changed with Alpha5 and later, so this example doesn't work either.  I have tried modifying this example to work with the newer release, but without much luck.

       

      We had been running unit tests by creating an embedded container in our test setup code, but with some recent changes and updating to v3.1 of the embedded container we are having problems with that, it exhausts as much heap space as we give it, we have tried values up to 3GB, so we are hoping that Arquillian will be a better framework for our testing.

       

      Does anyone have a functioning example that shows the setup for the latest version of Arquillian to test using embedded-glassfish-3.1 and clearly shows how to configure a custom datasource and reference an existing persistence.xml ?

       

      Thanks in advance for any help or advice !!

       

      - Joel -