2 Replies Latest reply on Jul 5, 2011 1:53 PM by vlari

    Is the REST interface available by default in HornetQ standalone?

    vlari Newbie

      Hi,

       

      I create a jms queuetestQueue) started Hornet in standalone mode:

       

      {code}

      [main] 17:23:05,639 INFO [org.hornetq.core.server.impl.HornetQServerImpl]  trying to deploy queue jms.queue.testQueue

      [main] 17:23:05,738 INFO [org.hornetq.core.remoting.impl.netty.NettyAcceptor]  Started Netty Acceptor version 3.2.3.Final-r${buildNumber} localhost:5445 for CORE protocol

      [main] 17:23:05,742 INFO [org.hornetq.core.remoting.impl.netty.NettyAcceptor]  Started Netty Acceptor version 3.2.3.Final-r${buildNumber} localhost:5455 for CORE protocol

      [main] 17:23:05,743 INFO [org.hornetq.core.server.impl.HornetQServerImpl]  Server is now live

      [main] 17:23:05,745 INFO [org.hornetq.core.server.impl.HornetQServerImpl]  HornetQ Server version 2.2.5.Final (HQ_2_2_5_FINAL_AS7, 121) [40053773-a690-11e0-8faa-005056c00008] started

      {code}

       

      But when I  do a HEAD query on my testQeue with:

       

      {code}

      curl -v -X HEAD http://localhost:5455/queues/jms.queue.testQueue

      {code}

      or :

       

      {code}

      curl -v -X HEAD http://localhost:5445/queues/jms.queue.testQueue

      {code}

       

      I get this message in the hornet console:

       

      {code}

      [hornetq-failure-check-thread] 17:24:41,754 WARNING [org.hornetq.core.protocol.core.impl.RemotingConnectionImpl]  Connection failure has been detected: Did not receive data from /127.0.0.1:51986. It is likely the client has exited or crashed without closing its connection, or the network between the server and client has failed. You also might have configured connection-ttl and client-failure-check-period incorrectly. Please check user manual for more information. The connection will now be closed. [code=3]

      {code}

       

      I went through the documentation but could not find any specific configuration params from enabling the REST API in standalone mode.

       

      Am I doing something wrong? Could it be that I'm using the wrong port #? Do I have to enable REST? If yes, how?

       

      Thanks.

       

      VincentL