3 Replies Latest reply on Jul 15, 2011 2:01 AM by arun kumar

    Trouble with running JSFUnit 2.0Beta1  & Jetty

    arun kumar Newbie

      Hi All,

      i was able to pass the JSFUnit on JbossAs6.

       

      but facing the problem with : "mvn -Pjetty-embedded test"

       

      find the error in the attachment.

       

      if u have any solution or work around plese update ...

       

       

      Thanks in Advance...

       

      -Arun

        • 1. Re: Trouble with running JSFUnit 2.0Beta1  & Jetty
          Stan Silvert Master

          Hi Arun,

           

          I don't have time to dig deep into your problem, but I've found that sometimes it helps to run mvn in offline mode for the jetty-embedded tests:

           

          mvn -o -Pjetty-embedded test

           

          Stan

          • 2. Re: Trouble with running JSFUnit 2.0Beta1  & Jetty
            arun kumar Newbie

            Hi Stan,

             

            i tried this : mvn -o -Pjetty-embedded test

             

            but same problem...

             

            Thanks & Regards,

            -Arun

            • 3. Re: Trouble with running JSFUnit 2.0Beta1  & Jetty
              arun kumar Newbie

              Hi Stan,

               

              is there any Depricated URL For the Follwing jars :

               

              Caused by: org.jboss.shrinkwrap.resolver.api.ResolutionException: Unable to resolve an artifact
              at org.jboss.shrinkwrap.resolver.impl.maven.MavenBuilderImpl.resolveAsFiles(MavenBuilderImpl.java:324)
              at org.jboss.shrinkwrap.resolver.impl.maven.MavenBuilderImpl.resolveAsFiles(MavenBuilderImpl.java:293)
              at org.jboss.shrinkwrap.resolver.impl.maven.MavenBuilderImpl$MavenArtifactsBuilderImpl.resolveAsFiles(MavenBuilderImpl.java:712)
              at org.jboss.jsfunit.example.hellojsf.HelloJSFTest.prepareForJetty(HelloJSFTest.java:76)
              at org.jboss.jsfunit.example.hellojsf.HelloJSFTest.createDeployment(HelloJSFTest.java:66)
              ... 61 more
              Caused by: org.sonatype.aether.resolution.ArtifactResolutionException: Could not find artifact com.sun.faces:jsf-api:jar:2.0.4-b03 in central (http://repo1.maven.org/maven2)
              at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:499)
              at org.sonatype.aether.impl.internal.DefaultRepositorySystem.resolveArtifacts(DefaultRepositorySystem.java:253)
              at org.sonatype.aether.impl.internal.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:283)
              at org.sonatype.aether.impl.internal.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:315)
              at org.jboss.shrinkwrap.resolver.impl.maven.MavenRepositorySystem.resolveDependencies(MavenRepositorySystem.java:176)
              at org.jboss.shrinkwrap.resolver.impl.maven.MavenBuilderImpl.resolveAsFiles(MavenBuilderImpl.java:316)
              ... 65 more
              Caused by: org.sonatype.aether.transfer.ArtifactNotFoundException: Could not find artifact com.sun.faces:jsf-api:jar:2.0.4-b03 in central (http://repo1.maven.org/maven2)
              at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$4.wrap(WagonRepositoryConnector.java:930)
              at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$4.wrap(WagonRepositoryConnector.java:925)
              at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$GetTask.flush(WagonRepositoryConnector.java:681)
              at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$GetTask.flush(WagonRepositoryConnector.java:675)
              at org.sonatype.aether.connector.wagon.WagonRepositoryConnector.get(WagonRepositoryConnector.java:420)
              at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:411)

               

              Thanks & Regards,

              -Arun